If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Not only "autoFill" Url you are typing but open tab

RESOLVED DUPLICATE of bug 559878

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 559878
7 years ago
7 years ago

People

(Reporter: Jake, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre

When you enabled autoFill, sometimes you can't typing Urls that start with "M",because the "M" you typied will be replaced with an open tab's Url whose name (not address) starts with "M".

Reproducible: Always

Steps to Reproduce:
1.Enable Autofill at about:config browser.urlbar.autoFill;true
2.Open this site and bookmark it(otherwide it won't autofill). Its name starts with "M"
https://forums.addons.mozilla.org/viewforum.php?f=11&sid=9cfc50d74c9bf43593180e8ad915c08a
3.Switch to another tab, activate the Urlbar and try to type any Url starts with "M".
Actual Results:  
You can type Url at all, the "M" you typed was raplaced with said open tab.


Im using b8pre, but I tried b7rc, the results are the same.
I think the culprit is "switch to tab", I strongly suggest FF can allow users to disable it. A lot of people are complaining about it.
http://forums.mozillazine.org/viewtopic.php?f=38&t=1977593
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

7 years ago
Mistyping....
Actual Results:  
You can't type Url at all, the "M" you typed was raplaced with said open tab.

Comment 2

7 years ago
Not a security-sensitive bug. It sounds like a real bug, but I'm pretty sure that this preference is not exposed in the UI and is therefore not supported.
Group: core-security
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Not a security-sensitive bug. It sounds like a real bug, but I'm pretty sure
> that this preference is not exposed in the UI and is therefore not supported.
What do you mean? You mean you can't set autoFill in the UI so it's supposed to be buggy?
(In reply to comment #3)
> What do you mean? You mean you can't set autoFill in the UI so it's supposed to
> be buggy?
It means we don't exactly support it, and at this point in the release cycle, I don't expect we'll take fixes to it either (although if the patch is very simple and comes with tests, I may be wrong!).
(Reporter)

Comment 5

7 years ago
As long as it's been comfirmed(takes 10 seconds to do it), take your time.I know it's not urgent. but still, any chance it will be fixed before next rc(b8 rc)? I suppose it's long enough.
(Reporter)

Comment 6

7 years ago
I really think you guys should consider giving users the option to disable "switch to tab",for a lot people it does nothing good but causing trouble.
(Reporter)

Comment 7

7 years ago
There is one more thing I shuold add, if you can't reproduce it, try to clear history or set Ulrbar Suggestion with "bookmark" in stead of " bookmark and history", your browsering history might override it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559878
You need to log in before you can comment on or make changes to this bug.