Last Comment Bug 559878 - browser.urlbar.autoFill replaces typed characters in awesomebar with tab match URL characters
: browser.urlbar.autoFill replaces typed characters in awesomebar with tab matc...
Status: RESOLVED FIXED
[switch-to-tab][needs 566489]
: regression
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: x86 Linux
: -- normal with 5 votes (vote)
: ---
Assigned To: Michael Ventnor
:
: Marco Bonardo [::mak]
Mentors:
: 581703 599678 610348 633682 644091 653845 658447 667450 680766 688942 (view as bug list)
Depends on: 659437 566489
Blocks: switch-to-tab
  Show dependency treegraph
 
Reported: 2010-04-16 11:12 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-06-09 02:12 PDT (History)
34 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
screenshot after typing "mo" (65.24 KB, image/png)
2010-04-16 11:12 PDT, Matt Brubeck (:mbrubeck)
no flags Details
moz-action (40.71 KB, image/png)
2010-07-07 12:00 PDT, imradyurrad
no flags Details
Screenhot 1 (30.50 KB, image/jpeg)
2011-12-16 19:49 PST, ffbug
no flags Details

Description Matt Brubeck (:mbrubeck) 2010-04-16 11:12:15 PDT
Created attachment 439575 [details]
screenshot after typing "mo"

Steps to reproduce:
1. Type some text in the awesomebar that matches an open tab.

Results: Text that you typed is replaced with the URI of the open tab.If you continue typing, the first N characters of the URI replace the N characters you typed.  (In the attached screenshot, the match appeared after I type "mo" - if I type "motown" then "httown" appears in the awesomebar.)

I can't reproduce this with just any tab, but for affected URLs it happens consistently.  I think it might happen on pages with higher suggestion "scores" (frecency, etc.) but I'm not sure.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-04-16 11:13:31 PDT
Do you have browser.urlbar.autoFill set to true?
Comment 2 Matt Brubeck (:mbrubeck) 2010-04-16 11:25:37 PDT
(In reply to comment #1)
> Do you have browser.urlbar.autoFill set to true?

Ah, yes I do.  Updating the summary to show this.  The problem does not exist with browser.urlbar.autoFill = false.
Comment 3 Matt Brubeck (:mbrubeck) 2010-04-21 15:38:26 PDT
Aha! This happens whenever the typed text begins with characters from "moz-action:".
Comment 4 imradyurrad 2010-07-07 11:12:37 PDT
(In reply to comment #3)
> Aha! This happens whenever the typed text begins with characters from
> "moz-action:".

Why is moz-action even shown in the urlbar?
Comment 5 Matt Brubeck (:mbrubeck) 2010-07-07 11:37:40 PDT
"moz-action:" does not actually appear anywhere onscreen (in the urlbar or in the autocomplete menu), but the URL is autofilled as if it started with "moz-..." instead of "http..."  So I type "mo" and end up with "ht" in the urlbar.
Comment 6 imradyurrad 2010-07-07 12:00:03 PDT
Created attachment 456316 [details]
moz-action
Comment 7 imradyurrad 2010-07-07 12:00:37 PDT
(In reply to comment #5)
> "moz-action:" does not actually appear anywhere onscreen (in the urlbar or in
> the autocomplete menu), but the URL is autofilled as if it started with
> "moz-..." instead of "http..."  So I type "mo" and end up with "ht" in the
> urlbar.

Arrow over to where it says "switch to tab" and it does.
Comment 8 Matt Brubeck (:mbrubeck) 2010-07-07 12:05:40 PDT
(In reply to comment #7)
> (In reply to comment #5)
> > "moz-action:" does not actually appear anywhere onscreen (in the urlbar or in
> > the autocomplete menu)
> Arrow over to where it says "switch to tab" and it does.

I can't reproduce this in the latest trunk nightly. It sounds like a different bug.  (When I use the arrow keys to highlight a tab match, the urlbar says "Switch to tab: http://...")
Comment 9 imradyurrad 2010-07-07 12:23:21 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #5)
> > > "moz-action:" does not actually appear anywhere onscreen (in the urlbar or in
> > > the autocomplete menu)
> > Arrow over to where it says "switch to tab" and it does.
> 
> I can't reproduce this in the latest trunk nightly. It sounds like a different
> bug.  (When I use the arrow keys to highlight a tab match, the urlbar says
> "Switch to tab: http://...")

Using the latest hourly.
Comment 10 imradyurrad 2010-07-07 12:28:51 PDT
Disregard that. Location bar 2 addon caused it.
Comment 11 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-07-25 18:54:54 PDT
*** Bug 581703 has been marked as a duplicate of this bug. ***
Comment 12 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-07-25 18:58:50 PDT
Ok, this kinda makes sense. Not sure how to fix it, mind you. Although, having bug 566489 fixed would make this a non-issue.
Comment 13 Dietrich Ayala (:dietrich) 2010-08-18 04:58:07 PDT
Blocking+ due to regression of long-standing well-known pref.
Comment 14 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-08-18 16:17:09 PDT
Any reason this needs to block beta5, rather than final (or betaN)?

(There's no chance I can get to this before beta5)
Comment 15 Drew Willcoxon :adw 2010-09-27 23:25:02 PDT
*** Bug 599678 has been marked as a duplicate of this bug. ***
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-11-08 13:24:58 PST
*** Bug 610348 has been marked as a duplicate of this bug. ***
Comment 17 Jake 2010-11-16 00:55:46 PST
Is this too easy or too hard? why takes so long?
Comment 18 Johnathan Nightingale [:johnath] 2010-12-15 09:23:30 PST
Can't block on non-standard pref
Comment 19 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-02-11 22:34:44 PST
*** Bug 633682 has been marked as a duplicate of this bug. ***
Comment 20 Frank Maas 2011-03-23 03:30:25 PDT
*** Bug 644091 has been marked as a duplicate of this bug. ***
Comment 21 Dietrich Ayala (:dietrich) 2011-04-21 03:11:43 PDT
Blair, if you're not working on this, can you summarize what would need to be done to fix it, so others can jump in?
Comment 22 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-05-01 18:36:16 PDT
(In reply to comment #21)
> summarize what would need to be done to fix it

Step 1: Wait until bug 566489 is fixed.
Step 2: Profit!

Bug 566489 will have the lovely side-effect of inadvertently fixing this bug.

Assigning to the owner of bug 566489, just so no one else accidentally picks it up.
Comment 23 Phil Ringnalda (:philor) 2011-05-06 19:53:24 PDT
(In reply to comment #22)
> Assigning to the owner of bug 566489, just so no one else accidentally picks
> it up.

Well, except you made the person who attached a patch there clear back in September of last year the QA contact of this bug, not the assignee.
Comment 24 Thomas Ahlblom 2011-05-19 21:06:20 PDT
*** Bug 658447 has been marked as a duplicate of this bug. ***
Comment 25 Michael Ventnor 2011-05-24 00:53:07 PDT
Bug 566489 landed, so this bug should be fixed too.
Comment 26 Vlad [QA] 2011-05-26 06:12:23 PDT
Verified fixed on Mozilla/5.0 (X11; Linux i686; rv:6.0a2) Gecko/20110526 Firefox/6.0a2
Comment 27 Matt Brubeck (:mbrubeck) 2011-05-26 16:10:23 PDT
Reopened due to back out of bug 566489.
Comment 28 Sav 2011-06-27 06:46:20 PDT
Didn't know which bug form to fill this out in, the URL trimming replaces the letter h with this.
Comment 29 Thomas Ahlblom 2011-06-27 11:30:08 PDT
*** Bug 667450 has been marked as a duplicate of this bug. ***
Comment 30 Dietrich Ayala (:dietrich) 2011-06-28 19:25:43 PDT
Bug 566489 looks to be abandoned again. For now can we change 'moz-action' to something which is unlikely to be typed by a human? Would that work around the problem? Is there a reason to have it be human-readable?
Comment 31 Michael Ventnor 2011-06-29 03:06:31 PDT
(In reply to comment #30)
> Bug 566489 looks to be abandoned again. For now can we change 'moz-action'
> to something which is unlikely to be typed by a human? Would that work
> around the problem? Is there a reason to have it be human-readable?

It's not abandoned, it's just being rewritten.
The new approach will be synchronous and should still fix this bug.
Comment 32 Bur 2011-07-22 13:39:15 PDT
If it helps, the bug seems only to happen when the letter 'h' is typed. With all else the autofill feture works fine for me.
Comment 33 Dietrich Ayala (:dietrich) 2011-07-22 20:28:53 PDT
Bug 566489 is complicated, and is looking at a possible second backout.

The wallpaper approach suggested in comment #30 will mitigate this bug with no change to code. Blair, is this a reasonable way to fix this in the short term?
Comment 34 Mimi Burned 2011-10-10 20:09:44 PDT
I can confirm that this is only happening when typing the letter 'h', it gets changed to 'w'
Comment 35 Loic 2011-11-03 14:14:27 PDT
I guess Bug 678352 is a dupe of this bug.
Comment 36 Ryan Curtis 2011-11-09 14:00:38 PST
For me this bug happens when I type the letter 'h' in the bar, and it is changed to an 'f'.  The autofill shows "fedoraproject.org" as the match with the H in "Fedora Project Homepage" highlighted.  If I type quickly enough, a 'h' will stay an 'h', but if I hesitate at all it will be changed to an 'f'.
Comment 37 ffbug 2011-12-16 19:44:28 PST
It isn't just with 'h'. Even 'm' turns into a 'w'. Here's what's happening - As you start with the 1st character of the URL you are trying to get to, the auto-complete kicks in, just like in previous versions. 
The difference now is, even though the typed character is shown in bold, the entire URL after the 1st character is highlighted. When the 2nd character is typed, the 1st highlighted character is replaced with the typed character. Since 'www' is the URL prefix in most cases, 'w' is the 1st un-highlighted. So, typing 'ho' for www.hotmail.com changes into a 'wo' Notice the bold 'h' when typing and also notice the entire URL is highlighted, except for the 1st w in www. Same thing happens if I try typing a 'm' for www.msnbc.msn.com. The URL turns into 'ws'
Comment 38 ffbug 2011-12-16 19:49:46 PST
Created attachment 582468 [details]
Screenhot 1

After typing 'h', notice the 'h' in all shown URLs is bold, however, the entire URL is highlighted.
Comment 39 ffbug 2011-12-18 09:22:15 PST
Workaround: Changed the "browser.urlbar.delay" setting to 500. This slows down the autocomplete suggestions and allows for time to enter the 2nd character (eg:ho) which then displays the correct suggestions.
Comment 40 Tim (fmdeveloper) 2011-12-23 17:30:12 PST
*** Bug 688942 has been marked as a duplicate of this bug. ***
Comment 41 Tim (fmdeveloper) 2011-12-23 17:35:29 PST
*** Bug 680766 has been marked as a duplicate of this bug. ***
Comment 42 Tim (fmdeveloper) 2011-12-23 17:55:09 PST
*** Bug 653845 has been marked as a duplicate of this bug. ***
Comment 43 Matt Brubeck (:mbrubeck) 2012-01-20 08:09:11 PST
This was fixed again by the re-landing of bug 566489.

Note You need to log in before you can comment on or make changes to this bug.