Names of other bookmarks' folders are changed after adding a new bookmark folder and a new bookmark

RESOLVED DUPLICATE of bug 477687

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 477687
7 years ago
7 years ago

People

(Reporter: greentree2010, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

Name of an existing bookmark folder has been changed after adding a new bookmark folder and a new bookmark link in it, to the name of the new bookmark folder. 
After adding a new bookmark link, in a new bookmark folder, another bookmark folder's name has changed to the name of the new folder and afterwards I have two bookmark folders with the same name, but the old one's name should not be changed to the new one's name, because I did not want it. 
Language of Firefox: Polish. 
The description above regards one specific bug, which occurred today. However, similar bugs have occurred already many times and not only on this computer, but also on another computer, which I use at work (also WinXP, but the same Firefox). They have always a similar scenario: I add a bookmark and notice, that some bookmark folders have been afterwards moved or their names have been moved or their contents have been moved somewhere else. I do not do anything else than just simply add a bookmark, with no changes in the structure of the bookmark folders other than just adding one or more new bookmark folders, without moving or renaming any other folders. 
This error does not happen every time - it occurs from time to time. 

Reproducible: Sometimes

Steps to Reproduce:
1. Check if you already have some bookmark folders, containing bookmark links in your bookmarks. - If you don't have any, then add some bookmark folders and links (it doesn't matter to which web pages the bookmarks refer to). 
2. Remember the current structure and contents of your bookmarks (bookmark folders and links). 
3. Go to any web site, e.g. http://www.google.pl
4. Add the current web site to the bookmarks: 
4.1. In the menu at the top of Firefox choose "Bookmarks > Add bookmark..." (in Polish: "Zakładki > Dodaj zakładkę...")
4.2. Create a new folder, in which the bookmark will be added. 
4.3. Click the confirmation button (in Polish: "Gotowe"). 
5. Check, if the bookmark has been correctly added. 
6. Check, if the names and contents of other bookmark folders have been changed. 
7. If the names and contents of other (previously existing) bookmark folders haven't been changed, then repeat steps 3-7 as long, as you reproduce the bug (it doesn't happen always, so you must try multiple times before you reproduce it). 
Actual Results:  
Name of at least one previously existing bookmark folder has been changed. (This error occurs sometimes, not always.)

Expected Results:  
The bookmark has been added and the names and contents of other bookmark folders have remained unchanged.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477687
You need to log in before you can comment on or make changes to this bug.