<xsl:output doctype-system="some.dtd"/> not working

VERIFIED DUPLICATE of bug 61044

Status

()

P3
normal
VERIFIED DUPLICATE of bug 61044
18 years ago
17 years ago

People

(Reporter: gartside, Assigned: keith)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I Just submitted this from my mozilla, but it didnt seem to work. So I'm
resubmitting from netscape (and a different machine). The machine running
mozilla has the following user-agent: Mozilla/5.0 (X11; U; Linux 2.2.13-7mdksmp
i686; en-US; m18) Gecko/20000928.
---------------

A directive in an xsl sheet such as: <xsl:output doctype-system="mathml.dtd"/>
doesnt seem to be having the desired effect -ie- the output document having
<!DOCTYPE html SYSTEM @mathml.dtd"> in its preamble.

A test style sheet, input xml doc and transformiix's output follow.

My mozilla (and transformiix) are up to date (as of Thursday 23rd Nov 2000).

I apologise if the error is mine and not transformiix. I have checked against
4xslt 's output (python xslt transformer), and that does output <!DOCTYPE html
SYSTEM etc>.

---

Stylesheet:

<?xml version="1.0"?>

<!DOCTYPE  html  SYSTEM "mathml.dtd">

<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">



<xsl:output method="xml"/>
<xsl:output doctype-system="mathml.dtd"/>
<xsl:output indent="yes"/>

<!-- main rule for document element -->
<xsl:template match="document">

<html xmlns:math="http://www.w3.org/1998/Math/MathML"
xmlns="http://www.w3.org/TR/REC-html40">

<head>
<title>Test for Doctype</title>
</head>


<body bgcolor="#FFFFFF" text="#000000">

<font color="blue" style="text-align: center">
<b>Test for Doctype</b></font>
</body>
</html>

</xsl:template>

</xsl:stylesheet>

Input xml file:

<?xml version="1.0"?>

<document>

Stuff....


</document>

Output xml file:

<?xml version="1.0"?>
<html xmlns:math="http://www.w3.org/1998/Math/MathML" xmlns="http://www.w3.org/T
R/REC-html40">

<head>
<title>Test for Doctype</title>
</head>
<body bgcolor="#FFFFFF" text="#000000">
<font color="blue" style="text-align: center">
<b>Test for Doctype</b>
</font>
</body>

</html>

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 61044 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Summary: <xsl:output doctype-system="some.dtd"/> not working → <xsl:output doctype-system="some.dtd"/> not working

Comment 2

17 years ago
bitching buttons, verfication spam
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.