Custom CSS rules aren't taking effect

VERIFIED FIXED in 0.9.2

Status

--
blocker
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: craigcook, Assigned: sheppy)

Tracking

unspecified
0.9.2

Details

(URL)

(Reporter)

Description

8 years ago
Custom CSS rules added via the Mindtouch control panel aren't taking effect on the staging server. I can't reproduce the bug locally so it's possible this is related to the other server/config issues.
(Reporter)

Updated

8 years ago
Target Milestone: --- → 0.9.2

Comment 1

8 years ago
Sheppy:  Can you provide some examples of where this is broken on stage9 so we can see what this looks like?  Thanks!

Updated

8 years ago
Assignee: nobody → jeremy.orem+bugs
(Assignee)

Comment 2

8 years ago
The most obvious and simple case is here:

https://developer-stage9.mozilla.org/en/error_console

Compare to:

https://developer.mozilla.org/en/error_console

The box at the top that starts with "Gecko 2.0 note" is missing all of its styling on the assorted divs that make up that box.
(Reporter)

Comment 3

8 years ago
Sheppy, can you give me admin access on stage9 so I can take a look? Username is craigcook
(Assignee)

Comment 4

8 years ago
done.
(Reporter)

Comment 5

8 years ago
It looks like it's the same caching/something problem that's breaking the custom toolbar. Looking at https://developer-stage9.mozilla.org/skins/common/custom_css.php (which should be generated server-side with the custom CSS rules) shows the comment:

/* ETagCache Error: Missing file: cache-developer-stage9.mozilla.org.9.12.3-b34bf80cb4ea5e9a5b78de546efca525 */

Similar to what we're seeing in bug 610504. So it seems like these settings are being saved in the DB, but the files aren't being generated on the server? Maybe some folders/files need to be made server-writable?

Comment 6

8 years ago
sheppy: can you please connect with mindtouch to see if we can get some help on this?  do we usually just add their support guys to bugs?
(Assignee)

Comment 7

8 years ago
I've filed a ticket with MindTouch support.

Updated

8 years ago
Assignee: jeremy.orem+bugs → eshepherd
(Reporter)

Comment 8

8 years ago
This thread (http://forums.developer.mindtouch.com/showthread.php?t=6989) at the Mindtouch forums describes the exact same problem, and there it was solved by making the cache folder writable.

So if we chmod /skins/common/cache/ that might do it.

Comment 9

8 years ago
Alright, it is now writable to dekiwiki and apache.
(Assignee)

Comment 10

8 years ago
Custom CSS is now working correctly, but the editor toolbar is not.
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

8 years ago
(In reply to comment #10)
> Custom CSS is now working correctly, but the editor toolbar is not.

I suspect the editor needs a different file/folder made writable but I'm not sure which. But we can discuss that over on bug 610504. 

Existing custom styles are in effect and I just made a test edit to verify that changes take effect as well, so I think we can call this resolved for now.
verified fixed https://developer.mozilla.org/en/error_console
Status: RESOLVED → VERIFIED
Version: MDN → unspecified
Component: Deki Infrastructure → Other
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.