Closed Bug 610536 Opened 12 years ago Closed 12 years ago

Thunderbird.next should be a Mail folders sidebar and folder & message tabs in Firefox

Categories

(Thunderbird :: General, enhancement)

x86_64
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 252425

People

(Reporter: info, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre
Build Identifier: 

I'm sure I'm not the first to suggest this, but I couldn't find a bug for it, and it doesn't even seem to be under consideration for https://wiki.mozilla.org/Thunderbird:Thunderbird_Post_3.1_Plan and other TB planning pages.

The Firefox 4 push to make disparate dialogs into browser tabs makes me again wonder why Thunderbird isn't a Firefox extension.

From a UI point of view, it's "straightforward".
* Tb's folders pane becomes a View > Sidebar > "Mail folders".
* A specialized mail tab shows the folder contents and optionally the current message pane (with the same layout options).
* You can "Open message in new tab" exactly as in TB 3.1.

Some amazingly powerful things come out of this.
* Tagging works across web pages and mail messages.
* You can bookmark a mail message or folder, and then bring it up from the awesome bar!
* You can organize mail folders and messages as well as web pages in Tab Groups (aka Tab Candy).
* Mail folders and messages become first-class URLs (although local like file: URLs) in Firefox.
* All the Fx add-ons that work with HTML views become available to mail messages.
* Places search could work across bookmarks, history AND mail messages!
* You can manage mail attachments and downloads (the way 90% of the files on my computer got there) within one program.

Other motivations:
* Firefox 4.0 + Thunderbird 3.1 are killing my 1 GB PC's performance, and it seems they'll never get to sharing a libxul, let alone a XUL runtime.
* Mozilla is working on various Contacts initiatives for its browser, but I've got a Tb address book already.  Splitting contacts between the two programs will drive users away from Tb.
* etc. etc.

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird and Firefox, press Ctrl-B in the latter.
2. Stare at screen, squint and defocus, unfocused until the two meld together.

Actual Results:  
They're separate apps, but they look awfully similar.

Expected Results:  
Thunderbird as an extension looks like the future, and under the covers mail folders and messages as local URLs that you manage in your browser is the right architecture.

I know about SeaMonkey and am trying out SeaMonkey 2.1 beta.  Wanting to view and manage mail folders and mail messages in Firefox tabs is not the same as wanting an integrated web suite.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 252425
You need to log in before you can comment on or make changes to this bug.