Mozilla terminates when font size is lowered with CTRL mousewheel

VERIFIED DUPLICATE of bug 54963

Status

()

Core
Event Handling
P3
critical
VERIFIED DUPLICATE of bug 54963
18 years ago
16 years ago

People

(Reporter: Joeri Alberty, Assigned: Brian Ryner (not reading))

Tracking

({crash})

Trunk
mozilla0.9
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Set in preferences Advanced/Mouse Wheel

Modifier Control,check make the text larger and smaller.

When a make de text very small (turning wheel endless) the browser stops working.

With CTRL - ..... it gets smaller than bigger and stays the original size.

The problem is the same with every URL

Mouse in use is Microsoft IntelliPoint (I think it is the same with othe mouses)

Comment 1

18 years ago
Tested on Linux RH6.2/gnome/sawfish/ installed build ID 2000112221

This actually froze X and keyboard as well, forcing me to power off the PC.
I wonder if there is a dup of this somewhere, but setting new for now.

To reiterate steps to reproduce:

-set prefs/advanced/mouse wheel to "make the text larger or smaller"
-click ok to dismiss prefs, then scrollwheel a little
-scrollwheel more, smaller and smaller text - give it a "run for it" by
scrolling fast.

Testpage was this very bug-report, and mouse-type doesn't have anything to do
with it (Logitech here)

Result: Mozilla froze, X froze, keyboard input froze.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
bryner, any idea?

Comment 3

18 years ago
dupe of 54963?

Comment 4

18 years ago
other font-size crashers: bug 59219, bug 49674.
Keywords: crash

Comment 5

18 years ago
No, not a duplicate.  At least, not on the surface?
Changing crasher bug milestone to mozilla0.9.
Target Milestone: --- → mozilla0.9
I don't think this is event system bug. Since bryner has one related (dupe?) of
this, reassigning.
Assignee: joki → bryner
(Assignee)

Comment 8

18 years ago

*** This bug has been marked as a duplicate of 54963 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
If you size down slowly, does this problem still occur?
If you first go to say 1% through the view menu, then size down, does it still
occur?

I suspect the problem is sending lots of "render me this text at this fontsize"
messages to the X server.

Comment 10

18 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
If you size down slowly, does this problem still occur?
YES (mozilla window close)
If you first go to say 1% through the view menu, then size down, does it still
occur?
YES (same)

Updated

16 years ago
QA Contact: bugzilla → gerardok
You need to log in before you can comment on or make changes to this bug.