Closed Bug 611408 Opened 9 years ago Closed 9 years ago

Tab candy ui is all broken

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 604381

People

(Reporter: jrmuizel, Unassigned)

Details

Attachments

(1 file)

Not sure if I can reproduce the problem.

The error console says:
Error: this[0] is undefined
Source File: chrome://browser/content/tabview.js
Line: 467

which is:

  // ----------
  // Function: val
  // Given a value, sets the receiver's value to it; otherwise returns what's already there.
  val: function iQClass_val(value) {
    Utils.assert(this.length == 1, 'does not yet support multi-objects (or null objects)');
    if (typeof value === "undefined") {
      return this[0].value;
    }

>>    this[0].value = value;
    return this;
  },
blocking2.0: --- → ?
Attached image screenshot
This error is in iQ.js.
I can, it seems, reproduce the problem after doing a session restore
Updating doesn't fix it. I can send the sessionstore.js to anyone who is interested
OS: Mac OS X → Windows 7
Dupe of bug 604381.
(In reply to comment #6)
> Dupe of bug 604381.

Definitely. Marking as dupe.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604381
blocking2.0: ? → ---
Jeff, do you have javascript.options.methodjit.chrome set to true?
Yes, it turns out I do.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.