Closed Bug 611592 Opened 9 years ago Closed 9 years ago

Backspace button on the keyboard acts like the browser's back button.

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: moz.teodosia, Assigned: mfinkle)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101031 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre Fennec /4.0b3pre

Pressing backspace button to delete text form a textfield the previously visited page is loaded instead of deleting the text. The issue is reproducible on both the software keyboard and hardware keyboard.

Devices: Motorola DROID 2, HTC Desire, Samsung Galaxy S Captivated.

Reproducible: Always

Steps to Reproduce:
1.Visit at least a site.
2.In the same tab go to www.google.com
3.Tap on the text field and start typing a word.
4.Press the backspace button from the keyboard.
Actual Results:  
The previously visited page is loaded.

Expected Results:  
The last typed letter should be deleted.
Also reproducible on build Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre)
Gecko/20101112 Firefox/4.0b8pre Fennec /4.0b3pre
Regression from bug 611240.
Attached patch patchSplinter Review
This patch changes the target of a CSS rule. The previous selector was blocking all keys from remote textboxes on desktop linux, bonly the backsapce key on Android. Might be a hard vs soft keyboard issue.

Anyway, this patch lets both desktop and Android function correctly. It alos does not dismiss the vkb on Android when panning content, which was the reason for adding the CSS in bug 605253.
Assignee: nobody → mark.finkle
Attachment #490079 - Flags: review?(21)
Duplicate of this bug: 611640
This bug is worse for hard keyboards. No text can be entered into a textbox.
Virtual keyboards are less affected.
pushed:
http://hg.mozilla.org/mobile-browser/rev/2811d31cc4e0
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101115 Namoroka/4.0b8pre Fennec/4.0b3pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101115 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.