Last Comment Bug 611670 - Drop the use of sendchange in favor of trigger, or equiv that keeps sourcestamp
: Drop the use of sendchange in favor of trigger, or equiv that keeps sourcestamp
Status: RESOLVED WORKSFORME
[l10n][automation]
:
Product: Release Engineering
Classification: Other
Component: General Automation (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Chris AtLee [:catlee]
:
Mentors:
Depends on:
Blocks: 698910
  Show dependency treegraph
 
Reported: 2010-11-12 07:24 PST by Axel Hecht [:Pike]
Modified: 2013-08-12 21:54 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Axel Hecht [:Pike] 2010-11-12 07:24:09 PST
The extensive use of sendchange makes our build status a confusing mess.

There shouldn't be anything in sendchange that we can't reproduce on top of scheduler db, hopefully. With http://buildbot.net/trac/ticket/1039, plain trigger should probably do it.

The dependent/triggered builds should keep the sourcestamp of the original build, as that's, for one, the right thing to do, and it will make reporting so easy that we don't need to restrict the build infrastructure to only change in ways that the reporting hacks wouldn't break. I.e., if our builds were organized such that the reporting on top just had to show what's there, we can improve our builds without worrying that the reporting would break, or how it would show today's and last week's builds.
Comment 1 Chris AtLee [:catlee] 2010-11-12 11:33:32 PST
This is something we've been thinking about for a while, so thanks for filing the bug!  We could actually use Trigger/Triggerable right now, but it makes the configs a bit ugly since all the Triggerable schedulers have to be active on each master.

I'm not sure I understand all that you're saying about reporting...In some cases you would share the same sourcestamp, but I'm not sure if that's true across the board?
Comment 2 Axel Hecht [:Pike] 2010-11-16 07:03:31 PST
(In reply to comment #1)
> I'm not sure I understand all that you're saying about reporting...In some
> cases you would share the same sourcestamp, but I'm not sure if that's true
> across the board?

The only challenge I saw was determening the sourcestamp for triggered l10n nightlies. There are arguments in favor of using the en-US sourcestamp and against. Like, it makes all the nightlies report is probably both pro and con, depending on how you look at it.
Comment 3 Chris AtLee [:catlee] 2012-03-09 10:52:38 PST
Axel, does build 'builduid' property cover what you need here? This is created by the scheduler for the builds, and propagated down to tests, repacks, etc.
Comment 4 Axel Hecht [:Pike] 2012-03-09 14:09:00 PST
I don't have concrete ideas these days. This might impact what can be done with the web reporting for l10n builds, though, which is now bug 698910.
Comment 5 Chris AtLee [:catlee] 2012-03-16 08:44:55 PDT
If you have some concrete changes we can make, please open up a new bug at that point. Thanks!

Note You need to log in before you can comment on or make changes to this bug.