Closed Bug 611945 Opened 12 years ago Closed 12 years ago

Panorama: Groups not shared between all windows

Categories

(Firefox Graveyard :: Panorama, enhancement)

x86
Windows 7
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 578512

People

(Reporter: jedakiah, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Panorama groups should be shared between all windows.  When a user clicks close on an open window it should close the panorama group/window, but not erase all of the other panorama groups.  This will enhance usability and prevent people from accidentally closing tabs hidden away by Panorama.  

Also, users should be able to open panorama groups in a new window.

Reproducible: Always




Some might feel that Panorama's purpose is to prevent a person from opening multiple windows and instead relying solely on tabs.  However, on a modern high resolution widescreen monitor or when a user has  two monitors there are frequently times when they wish to display two sets of information side-by-side.  And in those scenarios Panorama can easily be an inconvenience.  Furthermore it is quite easy to accidentally close the window that had all of your panorama tabs hidden in it and discover your mistake too late.
I think that should be an option, something like "Panorama -> share groups between windows"
(In reply to comment #1)
> I think that should be an option, something like "Panorama -> share groups
> between windows"

Agreed.
Yup! This is a thought we had a while ago. Turns out implementation is tricky and won't make the FF4.0 time line.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578512
While I hadn't reviewed the source I figured that would be the case, considering tabs are implemented inside of windows.  

Is this something that will likely be added in a future release?  Or, should I start promoting the idea amongst the mailing lists & forums to see how much support this idea would have?
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.