Support JSObject::swap between compartments

RESOLVED DUPLICATE of bug 601803

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 601803
7 years ago
7 years ago

People

(Reporter: gal, Assigned: gal)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(Whiteboard: [compartments])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
This is necessary for bug 601803, which blocks b8.
(Assignee)

Updated

7 years ago
Blocks: 601803
No longer blocks: 584237, 606077
No longer depends on: 601803
Keywords: regression
Whiteboard: [compartments]
(Assignee)

Updated

7 years ago
Assignee: general → gal
(Assignee)

Comment 1

7 years ago
Created attachment 490378 [details] [diff] [review]
patch
(Assignee)

Comment 2

7 years ago
Passes make check.
(Assignee)

Updated

7 years ago
Attachment #490378 - Flags: review?(mrbkap)

Comment 3

7 years ago
mrbkap, can we get a review here?
(Assignee)

Comment 4

7 years ago
Blake has a patch on top of this one which we use for testing. We will update the bug today.
Created attachment 492468 [details] [diff] [review]
patch

This patch works a little better, but hasn't been tested fully yet.
Attachment #490378 - Attachment is obsolete: true
Attachment #490378 - Flags: review?(mrbkap)
Progress here?  Trying to ship beta 8.
This work got rolled into bug 601803. Duping so we don't need to track these issues separately any more.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601803
You need to log in before you can comment on or make changes to this bug.