use timestamp in .eml filename on save

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
P3
enhancement
18 years ago
7 years ago

People

(Reporter: ptrourke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001122
BuildID:    2000112204

Would suggest that when new features are allowed, the following features be
added for saving emails (in order of priority):

1. On the Save As window, suggest the subject line followed by the timestamp as
a filename, or vice versa.


2. Allow user to save all emails in a given mailbox at once (select all, save
as), with the default file name being the subject followed by the time stamp, or
vice versa.


3. If possible, allow drag-and-drop exporting ala Outlook Express in Windows
(i.e., "select all" selects all the email messages in a given mailbox, and then
one can just drag them out to a folder/directory) - however, this feature might
be platform-dependent.

Reproducible: Always
Steps to Reproduce:
Feature enhancement.
Marking assigned to nobody@mozilla.org, which only means that a Netscape
engineer is not assigned to fix the bug/enhancement.  Feel free to take
ownership if you can code this.
Assignee: putterman → nobody
Marking as {RFE} and changing status to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Improve save mail features → {RFE} Improve save mail features

Comment 3

18 years ago
On the "Save As..." window, the suggested file name should include sender's
name, followed by timestamp, followed by subject.

The suggested file name should also have an extension representing the "Save as
type" pulldown. The only exception being "All Files (*.*)" which would not leave
an extension.

The options in the "Save as type" pulldown should list available extensions for
all options, not just "Mail Files (*.eml). A corrected pulldown would read as:

----------------------
Mail Files (*.eml)
All Files (*.*)
HTML Files (*.html)
Text Files (*.txt)
----------------------


A suggested file name should look something like:
sender_name_2001-01-08-12:34_subject.eml








Comment 4

16 years ago
What feels buggy to me is the following: If I choose "Mail files (*.eml)" in
"Save as..." dialog the mail is saved with all headers and even with attachments
-- OK so far.
But if I decide to change the file's extension to .txt it's saved in the "Text
Files (*.txt)" format without headers. I think this is too clever.
Mozilla should better ignore the modified extension and use the format I choose
below in the drop-down field.

Comment 5

16 years ago
*** Bug 174546 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
As per comment 5 : bug 174546 could've been avoided if a better summary was used
for this bug.

Also as far as i know, one rfe should be submitted per requested feature. So i
would actually propose to submit three new RFE's for the points addressed in
this bug report and mark THIS bug invalid (or a tracker bug).
Product: Browser → Seamonkey
Assignee: nobody → mail
QA Contact: esther

Comment 7

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 8

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 9

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 10

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 14

7 years ago
*** This bug has been confirmed by popular vote. ***
Ever confirmed: true

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: EXPIRED → ---

Comment 15

7 years ago
As per comment 0:
1. is a valid RFE, we're currently just using the subject plus a counter
2. is already implemented by using the current naming scheme, 
   so doing 1. would fix this as well
3. doesn't work under Linux, but should go into a new bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: {RFE} Improve save mail features → use timestamp in .eml filename on save
You need to log in before you can comment on or make changes to this bug.