clicking a few pixels down from "Plugins" makes "Available Updates" or "Recent Updates" pane appear

VERIFIED FIXED in mozilla2.0b11

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: fryn, Assigned: fryn)

Tracking

Trunk
mozilla2.0b11
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
STR:
1. Open Add-ons Manager.
2. Click when the cursor placed a few pixels down from the "Plugins" pane label.

Expected Results:
Nothing happens.

Actual Results:
The "Recent Updates" label and pane appears.
Looks like it depends on some settings but for me the "Available Updates" pane is shown.
OS: Mac OS X → All
Summary: clicking a few pixels down from "Plugins" makes "Recent Updates" pane appear → clicking a few pixels down from "Plugins" makes "Available Updates" or "Recent Updates" pane appear

Comment 2

7 years ago
Here WORKARUND maybe works.

.category[disabled="true"]
{
  border-top: 0px !important;
  border-bottom: 0px !important;
}

Updated

7 years ago
Duplicate of this bug: 619310
(Assignee)

Comment 4

6 years ago
Created attachment 506052 [details] [diff] [review]
patch

Removes border when disabled.
Assignee: nobody → fryn
Status: NEW → ASSIGNED
Attachment #506052 - Flags: review?(bmcbride)
(Assignee)

Comment 5

6 years ago
(In reply to comment #2)
> .category[disabled="true"]
> {
>   border-top: 0px !important;
>   border-bottom: 0px !important;
> }

Thanks, Alice, for the suggested fix.
Attachment #506052 - Flags: review?(bmcbride)
Attachment #506052 - Flags: review+
Attachment #506052 - Flags: approval2.0?
Attachment #506052 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 6

6 years ago
Pushed.

http://hg.mozilla.org/mozilla-central/rev/c566b1cd7df8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

6 years ago
Target Milestone should be mozilla2.0b11, but it's not available as an option at the moment, so I'll fill that in later.

Updated

6 years ago
Target Milestone: --- → mozilla2.0b11
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre

I don't think that we need a manual testcase here. Worth spending time on an automated one?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus-
(Assignee)

Comment 9

6 years ago
(In reply to comment #8)
> I don't think that we need a manual testcase here. Worth spending time on an
> automated one?

I don't think so. Trivial bug. Better to have engineering resources working on writing tests for more critical functionality in the Add-ons Manager.
(Assignee)

Updated

6 years ago
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.