Closed Bug 61222 Opened 19 years ago Closed 19 years ago

THe ALT attribute for HTML IMG Tag does not work

Categories

(Core :: Layout, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 25537

People

(Reporter: samrutha, Assigned: clayton)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001108
Netscape6/6.0
BuildID:    Mozilla/5.0 /20001108 Netscape6/6.0

If an ALt attibute has been defined for am IMG tag in a web page ,if the browse
is moved on the image with the ALT attribute,then the text defined in the ALt
attribut for the image should be displayed,this is not done.

Reproducible: Always
Steps to Reproduce:
Open the composer window,insert an image (choose a jpeg file )and type some
atlternative text and save it,see the source code for the file
<p><img SRC="BrwTestHTMLwolf.gif" ALT="You are looking Wolf" height=100 width=130>
this kind of source can be seen,the atlternative text that was defined will be
same as the one in the ALT attribute of the image tag.
Now open the same in the browser window ,move the mouse over the inage and see
if the alternative text that was given is displayed or not.


Actual Results:  The text defined in the ALt tag of the IMg tag is not dispayed
when the mouse is moved over the Image in the Browse window.

Expected Results:  The text defined in the ALt attribute of the Image tag has to
be diplayed.
The alt attribute is for *alternative* text--that is, text that is displayed
when the image is not displayed. The title attribute is the one to use for
information that may be displayed as a tooltip in addition to the image being
displayed.

See the HTML 4.01 spec for the exact definitions of alt and title. (And yes, the
title attribute works in IE, too.)

Also, this is not the place for reporting bugs in Netscape 6 unless the problem
also exists in a recent Mozilla nightly in which case the build id of that
Mozilla build should be indicated in the report.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
VERIFIED.  Although I have to disagree somewhat on the bugs reported here-if it 
is the most recent publicly released version of N6, I think this forum is proper 
for such reports...
Status: RESOLVED → VERIFIED
I agree Alt attribute is for an alternate text in case the image does not get 
loaded  but the Text in the ALT tag should be diplayed when the browser is moved 
over the image and this is how it behaves in IE and netscape4.61 version ,but 
does not do the same on Netscape 6 .
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
From bug 25537:

The 'alt' attribute should not be displayed as a tooltip, that is what the
'title' attribute is for. See bug 1995 and bug 1994.

*** This bug has been marked as a duplicate of 25537 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
VERIFIED again.  Whee!!!!
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.