Doesn't open Add-ons Manager tab when click [Manage Add-ons...]button in Options dialog

RESOLVED FIXED in Thunderbird 3.3a3

Status

Thunderbird
General
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Shadow912, Assigned: squib)

Tracking

unspecified
Thunderbird 3.3a3
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(blocking-thunderbird5.0 needed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101117 Thunderbird/3.3a2pre Build ID: 20101117033239

Doesn't open Add-ons Manager tab when click [Manage Add-ons...]button in Options dialog, General pane > Add-ons.

Reproducible: Always

Steps to Reproduce:
1. Open Options dialog, Tools > Options > General pane.
2. Click [Manage Add-ons...]button

Actual Results:  
Open broken/old Add-ons Manager dialog.


Expected Results:  
Open Add-ons Manager tab.


Same results on TB 3.3a1 build1, Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101116 Thunderbird/3.3a1 Build ID: 20101116152258.
(Reporter)

Updated

7 years ago
Depends on: 571759
This works for me in Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b8pre) Gecko/20101116 Thunderbird/3.3a1 I get the add-on manager in a new window, and yes it takes a while to load the content, but the content will load.

And maybe the content only loads when you switch views in that new window (ie go to plugins , then to addons etc ...)

Can you show a screenshot of what you are seeing
Confirming that it's empty on first load. but as explained in comment #1 it then refreshes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 612710
blocking-thunderbird5.0: --- → needed
Note: we can probably do something very similar to what Firefox does in their preference pane.
To be extra clear, what we should be doing here is to open the Add-on Manager in a new 3-pane window in a new tab.

It has to be a new 3-pane window because iirc Windows has a modal preferences dialog and you can't use an existing window there.
(Assignee)

Comment 5

7 years ago
Created attachment 514148 [details] [diff] [review]
Make a new 3pane pop up when clicking the button

This should fix the issue. Not too sure what I should do for testing. :Standard8, any ideas?
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #514148 - Flags: review?(bugzilla)
(Assignee)

Comment 6

7 years ago
Comment on attachment 514148 [details] [diff] [review]
Make a new 3pane pop up when clicking the button

Whoops, I meant to flag this for feedback, not review...
Attachment #514148 - Flags: review?(bugzilla) → feedback?(bugzilla)
Comment on attachment 514148 [details] [diff] [review]
Make a new 3pane pop up when clicking the button

I'm not sure if we can open a new window with an extra tab and not have it randomly timeout or things. If we can, then it would perhaps be a good idea to add a test, if not, we could just request a litmus test for now.

You need to fix the calling instance in the openWhatsNew function as well.
Attachment #514148 - Flags: feedback?(bugzilla) → feedback+
(Assignee)

Comment 8

7 years ago
Oh, that was intentional, since it defaults to "open in tab with no clickHandler", but I could change it to be more explicit if you think that matters.
(Assignee)

Comment 9

7 years ago
Comment on attachment 514148 [details] [diff] [review]
Make a new 3pane pop up when clicking the button

Well, the test I tried to write was getting timeouts like you were worried about, so we may have to go without tests for this. Flagging this for review, though I can change the openWhatsNew function as well if you think it matters.
Attachment #514148 - Flags: review?(bugzilla)
Comment on attachment 514148 [details] [diff] [review]
Make a new 3pane pop up when clicking the button

Ok, I guess modifying openWhatsNew isn't necessary, however please add a short bit of documentation for openContentTab giving a bit of info about the parameters and what happens if the now last two parameters aren't specified.

r=Standard8 with that added.
Attachment #514148 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 11

7 years ago
Created attachment 517508 [details] [diff] [review]
Add comment for openContentTab
Attachment #517508 - Flags: review+
(Assignee)

Comment 12

7 years ago
Whoops, forgot to obsolete the old patch. Oh well. Adding checkin-needed...
Keywords: checkin-needed
Attachment #514148 - Attachment is obsolete: true
Checked in: http://hg.mozilla.org/comm-central/rev/95afb3f1f6c9

Ludovic: can we cover this with a litmus test please?
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-litmus?(ludovic)
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a3
(Reporter)

Comment 14

7 years ago
When click [Manage Add-ons...] buttons which is opened from TB main window Options dialog, Open new TB window and Add-ons Manger tab on its window.
I think, it isn't necessary to open new TB window if TB main window exist.
(Assignee)

Comment 15

7 years ago
(In reply to comment #14)
> When click [Manage Add-ons...] buttons which is opened from TB main window
> Options dialog, Open new TB window and Add-ons Manger tab on its window.
> I think, it isn't necessary to open new TB window if TB main window exist.

See comment 4.
(Reporter)

Comment 16

7 years ago
Comment on attachment 517508 [details] [diff] [review]
Add comment for openContentTab

I think following method to get mail3pane window is better.

>      let mail3PaneWindow = Components.classes["@mozilla.org/appshell/window-mediator;1"]
>                                      .getService(Components.interfaces.nsIWindowMediator)
>                                      .getMostRecentWindow("mail:3pane");

let targets = Components.classes["@mozilla.org/appshell/window-mediator;1"].getService(Components.interfaces.nsIWindowMediator).getEnumerator("mail:3pane");
let mail3PaneWindow;
while (targets.hasMoreElements()) {
  let target = targets.getNext();
  target.QueryInterface(Components.interfaces.nsIDOMWindowInternal);
  if (target.location.href = "chrome://messenger/content/messenger.xul") {
    mail3PaneWindow = target;
    break;
  }
}
https://litmus.mozilla.org/show_test.cgi?id=15181
Flags: in-litmus?(ludovic) → in-litmus+
You need to log in before you can comment on or make changes to this bug.