Closed Bug 612920 Opened 10 years ago Closed 10 years ago

Include role="presentation" elements if they have relations

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 575976

People

(Reporter: davidb, Assigned: davidb)

References

(Blocks 1 open bug)

Details

(Whiteboard: [aria spec conformance])

W3C bug: http://www.w3.org/Bugs/Public/show_bug.cgi?id=9656

Example:
<input aria-labelledby="foo"/>
<div id="foo" role="presentation">I am a label</div>

We should keep the div in the tree because of the label relation.
Summary: Include role="presentation" elements if the have relations → Include role="presentation" elements if they have relations
Marco just asked me why would someone do this and I admit I can't remember. It was debated in the ARIA group though.
Yes, the example given above just looks like plain wrong markup to me. role="presentation" on that div is simply faulty markup, IMO.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575976
You need to log in before you can comment on or make changes to this bug.