if sidebar has focus, closing it should focus content area

VERIFIED DUPLICATE of bug 78440

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED DUPLICATE of bug 78440
18 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: matt)

Tracking

Trunk
mozilla0.9.2

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Open a webpage that can scroll vertically.
1. Open the CNN sidebar panel.
2. Click on some non-link text at the top. (now the sidebar "frame" has focus)
3. Press F9 (turn off sidebar).
4. Try to scroll vertically using the keyboard.

Result: focus is "lost", so you can't scroll using the keyboard, and you also 
can't use tab to move focus to somewhere useful.

Expected: up/down scrolling would work (content area should have focus).

It might make sense re-use the focus code that activates when you type into the 
location bar and press enter.

Similarly, for MailNews: whatever object has the focus by default in MailNews 
should get focus if the sidebar is closed while it has focus.

Comment 1

18 years ago
Yeah, I just saw this today.  Annoying...
Assignee: matt → blakeross

Updated

18 years ago
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: P3 → P4
Hardware: PC → All

Comment 2

18 years ago
I don't know why this works for opening the sidebar, but not closing it.  I 
thought adding an explicit |_content.focus()| would fix it, but it had no 
affect.  It seems like the content area _is_ getting the focus, since pressing 
tab sets focus to the first item in the page, but the arrow keystrokes don't 
seem to be getting to the content area.  saari, do you have any ideas?
Assignee: blakeross → matt
Severity: minor → normal
Status: ASSIGNED → NEW
Priority: P4 → --

Comment 3

18 years ago
The content.focus should work... If you don't do something like that, yeah, the
focus will be "lost" when you close the focused sidebar. That isn't easy to fix
since we don't have a concept of a focus chain or focus history if you will.
Much easier to try to get the sidebar to reset focus when it closes.
(Assignee)

Updated

18 years ago
Keywords: nsbeta1

Comment 4

18 years ago
nav triage team:

Marking nsbeta1+, p3
Priority: -- → P3
Whiteboard: nsbeta1+
nav triage team: 
matt - could you schedule this into mozilla0.9 as it is a beta stopper? 
thanks, Vishy

Comment 6

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 7

17 years ago
Moving nsbeta1+ from status whiteboard to keyword, marking mozilla0.9.1
Keywords: nsbeta1 → nsbeta1+
Whiteboard: nsbeta1+
Target Milestone: --- → mozilla0.9.1
as discussed in team meeting, moving all Nav+ team members nsbeta1+ P3 bugs from 
mozilla0.9.1 to mozilla0.9.2. 
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Reporter)

Updated

17 years ago
Depends on: 78440

Comment 9

17 years ago
This is a dup of 78440 which has a fix attached to it: similar to saari's
suggestion actually.

*** This bug has been marked as a duplicate of 78440 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.