Closed Bug 78440 Opened 20 years ago Closed 20 years ago

Closing sidebar with F9 key does not refocus on content area

Categories

(SeaMonkey :: Sidebar, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: samir_bugzilla, Assigned: samir_bugzilla)

References

Details

(Whiteboard: Fix in hand)

Attachments

(1 file)

When one opens the sidebar with F9, the idebar default panel opened should
receive focus.  When one closes the sidebar with F9 the content area should
receive focus.  Currently when one closes the sidebar with F9 the window content
area doesn't receive focus so key board navigation is not possible until the
user clicks in the content area.
Spun off issue from bug 58250.  Inheriting priority and milestone from bug 58250
since we have a fix as a side-effect of investigating bug 58250.

pchen, please r.
alecf, please sr.

Thanks.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.1
OS: Windows NT → All
Hardware: PC → All
Whiteboard: Fix in hand
Blocks: 61299
Are you aware of bug 78218? Since you've got a patch here, does this make bug
78218 a dup of this one?
sr=alecf
*** Bug 61299 has been marked as a duplicate of this bug. ***
r=timeless if you want it
[nsbeta1+ from dupe]
Keywords: nsbeta1+
*** Bug 78218 has been marked as a duplicate of this bug. ***
timeless, thanks for the review.
NilsE, this patch also fixes bug 78218.  Thanks for pointing this out.
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified in 5/11 build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.