Traceback: ValueError: unsupported format character 'S' (0x53) at index 45 on search-tools RSS feed

VERIFIED FIXED in 5.12.4

Status

addons.mozilla.org Graveyard
Public Pages
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: stephend, Assigned: kumar)

Tracking

unspecified
5.12.4

Details

(URL)

(Reporter)

Description

7 years ago
https://addons.allizom.org/pl/firefox/search-tools/video/format:rss is traceback-inducing:

Traceback (most recent call last):

  File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/contrib/syndication/views.py", line 34, in __call__
    feedgen = self.get_feed(obj, request)

  File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/contrib/syndication/views.py", line 106, in get_feed
    description = self.__get_dynamic_attr('description', obj),

  File "/data/amo_python/www/prod/zamboni/vendor/src/django/django/contrib/syndication/views.py", line 69, in __get_dynamic_attr
    return attr()

  File "/data/amo_python/www/prod/zamboni/apps/browse/feeds.py", line 129, in description
    return _(u'Search tools relating to %s') % self.category.name

ValueError: unsupported format character 'S' (0x53) at index 45

Updated

7 years ago
Duplicate of this bug: 613529
Assignee: nobody → kumar.mcmillan
Priority: -- → P2
Aha, the translator made a typo and copied the format string incorrectly.  The fix has been committed to svn here https://svn.mozilla.org/addons/trunk/site/app/locale/pl/LC_MESSAGES/messages.po

The fix is near the bottom of the page at:

#. L10n: %s is a category name.
#: apps/browse/feeds.py:129
msgid "Search tools relating to %s"
msgstr "Narzędzia wyszukiwania związane z kategorią %s"

(note the lower case %s which should fix it)


I'm not sure when this will show up on the site.  clouserw maybe knows?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
at some point in the future after I merge out l10n
(Reporter)

Comment 4

7 years ago
Verified FIXED on https://addons.allizom.org/pl/firefox/search-tools/video/format:rss.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.