Most Drop down menus/boxes do not appear with hardware acceleration.

VERIFIED FIXED in mozilla2.0b9

Status

()

Core
Graphics
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Andy Lenz, Assigned: bas)

Tracking

({qawanted, regression})

Trunk
mozilla2.0b9
x86
Windows 7
qawanted, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: GECKO20b7_20101104_RELBRANCH FIREFOX_4_0b7_RELEASE FIREFOX_4_0b7_BUILD1 

When ever I click on a drop down box, I can't see it and either have to use the arrow keys or can't select it at all. You could click on the "Reproducibility" menu below and have to use the arrow keys. I think the drop down box is there, but you can't see it. You can sometimes click where you think the choices are.

Reproducible: Always

Steps to Reproduce:
1.Open any site with a drop down menu.
2.Click on a drop down box.
3.Attempt to click on box.
Actual Results:  
I could not see the drop down box.

Expected Results:  
Show the drop down box so I can select something

See attachments
It is not a huge bug but it is very frustrating.
(Reporter)

Comment 1

7 years ago
***almost always reproducible***
Does disabling the hardware acceleration under the preferences | advanced helps here?
(Reporter)

Updated

7 years ago
Summary: All Drop down menus do not appear → Most Drop down menus do not appear
(Reporter)

Comment 3

7 years ago
Created attachment 492185 [details]
Example
(Reporter)

Updated

7 years ago
Attachment #492185 - Attachment description: webpage- My bug report page → Example
(Reporter)

Comment 4

7 years ago
Yes It did fix it, but should that happen? Are you working on it?
Thank You
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 5

7 years ago
resolved fixed? :) are we sure about that?
(Reporter)

Comment 6

7 years ago
Good point I will change description
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Updated

7 years ago
Summary: Most Drop down menus do not appear → Most Drop down menus/boxes do not appear with hardware acceleration.
(Reporter)

Comment 7

7 years ago
It happens only with hardware acceleration
Please post the graphic section from about:support
Component: Menus → Graphics
Product: Firefox → Core
QA Contact: menus → thebes
Version: unspecified → Trunk
(Reporter)

Comment 9

7 years ago
Note I disablabled hardaware acceleration upon suggestion.
Adapter DescriptionNVIDIA NVS 3100MVendor ID10deDevice ID0a6cAdapter RAM256Adapter Driversnvd3dum nvwgf2um,nvwgf2umDriver Version8.17.12.5738Driver Date6-27-2010Direct2D EnabledfalseDirectWrite EnabledfalseGPU Accelerated Windows0/1
Can you please upgrade your driver, i think there should be a new one from nvidia.
and of course enable the hardware acceleration back on if you test the new driver

Comment 11

7 years ago
I can confirm this bug using Firefox 4.0 Beta 7. With activated hardware acceleration _all_ drop down menus on websites are broken. Disabling HW acceleration "solves" the issue. I'm using Windows 7.

I'll attach a screenshot illustrating the issue.

about:support (HW accel disabled):
Grafik Karten-Beschreibung NVIDIA Quadro NVS 295 Vendor-ID 10de Geräte-ID 06fd  Karten-Ram 256 Karten-Treiber nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Treiber-Version 8.17.12.5721 Treiber-Datum 6-7-2010  Direct2D aktiviert false DirectWrite aktiviert false GPU-beschleunigte Fenster 0/2

Comment 12

7 years ago
Created attachment 494337 [details]
Screenshot showing broken drop down menu with HW acceleration enabled
Confirming based on screenshots and ask for blocking so it can be investigated.

Matthias, is it the latest version of the graphics driver, which you have installed?
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: qawanted

Comment 14

7 years ago
No, the driver is from 6-7-2010, as you can see from the about:support text in comment 11. This is my workplace computer, I will install the latest nvidia driver and minefield nightly tomorrow to check if the problem persists. Oh btw.: It's a x64 machine, if that matters.

Comment 15

7 years ago
- The problem persists with the latest minefield nightly (Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101201 Firefox/4.0b8pre)

- The problem is _solved_ using the latest drivers from nVidia for this specific chip set (driver version 259.81, released 2010.10.28)

Semi off-topic: I do understand that hardware acceleration is the way to go forward regarding rendering performance of modern web browsers. 
It just occurred to me what a support nightmare it becomes when users experience rendering bugs in fundamental things like drop down overlays because they have installed a bad combination of graphics card and driver. Sooner or later Firefox will have to implement a mechanism which reminds users that they should install a newer driver to avoid certain bugs...
(In reply to comment #15)
> - The problem is _solved_ using the latest drivers from nVidia for this
> specific chip set (driver version 259.81, released 2010.10.28)
> 
> Semi off-topic: I do understand that hardware acceleration is the way to go
> forward regarding rendering performance of modern web browsers. 
> It just occurred to me what a support nightmare it becomes when users
> experience rendering bugs in fundamental things like drop down overlays because
> they have installed a bad combination of graphics card and driver. Sooner or
> later Firefox will have to implement a mechanism which reminds users that they
> should install a newer driver to avoid certain bugs...

That's a good question. CC'ing some more ppl to check how we could handle those situations.

@Andy: Can you also please upgrade your driver to the latest version and check again with HW acceleration enabled?

Comment 17

7 years ago
  Graphics

        Adapter Description
        NVIDIA GeForce 9500 GT

        Vendor ID
        10de

        Device ID
        0640

        Adapter RAM
        512

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Driver Version
        8.17.11.9745

        Driver Date
        4-3-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10
Geräte-ID 06fd 
Device ID 0a6c
Device ID 0640

We might need to do some blocking here, but we need to investigate first. Stuart apparently sees this problem on his computer too. We should also ask NVIDIA for information about this; particularly, whether they've intentionally fixed problems related to this in their latest drivers.

One thing that people can help us with is finding out whether it's a particular part of hardware acceleration that causes this bug. Disable Direct2D only and see what happens?
blocking2.0: ? → final+
(In reply to comment #18)
> One thing that people can help us with is finding out whether it's a particular
> part of hardware acceleration that causes this bug. Disable Direct2D only and
> see what happens?

I see this bug. It's annoying to say the least. When I set gfx.direct2d.disabled to true, my drop down menus appear normally.


Some details from my about:support...

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre

[...]

Graphics

Adapter Description
NVIDIA NVS 3100M

Vendor ID
10de

Device ID
0a6c

Adapter RAM
512

Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

Driver Version
8.17.12.5738

Driver Date
6-27-2010

Direct2D Enabled
true

DirectWrite Enabled
true

GPU Accelerated Windows
1/1 Direct3D 10


I'm downloading a newer version of my drivers to see if that helps...

Updated

7 years ago
Duplicate of this bug: 617240

Comment 21

7 years ago
nVidia 9800M GTS, driver version: 263.06
Unfortunately I cannot install the drivers I downloaded directly from nvidia, and the Lenovo system drivers have not been updated by Lenovo yet. Thank you Lenovo. I love it when you don't let me update my drivers.
Bas, were you able to get information from NVIDIA on whether they intentionally fixed anything, so we can block older drivers?
Assignee: nobody → bas.schouten
Keywords: regression
Duplicate of this bug: 617934
(Assignee)

Updated

7 years ago
Duplicate of this bug: 607846
(Assignee)

Comment 26

7 years ago
Created attachment 497927 [details] [diff] [review]
Set GDI Compatible flag on swap chain

This appears to be a driver problem. We can work around it by setting the GDI compatible flag. Since this should have no negative effects I believe we should just do this.
Attachment #497927 - Flags: review?(jmuizelaar)
Comment on attachment 497927 [details] [diff] [review]
Set GDI Compatible flag on swap chain

># HG changeset patch
># Parent e7d4ff8c03ade467a887d836b23d0858374c7449
>
>diff --git a/gfx/layers/d3d10/LayerManagerD3D10.cpp b/gfx/layers/d3d10/LayerManagerD3D10.cpp
>--- a/gfx/layers/d3d10/LayerManagerD3D10.cpp
>+++ b/gfx/layers/d3d10/LayerManagerD3D10.cpp
>@@ -177,16 +177,20 @@ LayerManagerD3D10::Initialize()
>   swapDesc.BufferDesc.Height = 0;
>   swapDesc.BufferDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
>   swapDesc.BufferDesc.RefreshRate.Numerator = 60;
>   swapDesc.BufferDesc.RefreshRate.Denominator = 1;
>   swapDesc.SampleDesc.Count = 1;
>   swapDesc.SampleDesc.Quality = 0;
>   swapDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
>   swapDesc.BufferCount = 1;
>+  // We don't really need this flag, however it seems on some NVidia hardware
>+  // smaller windows do not present properly without this flag. This flag
>+  // should have no negative consequences by itsself. See bug 613790.

s/itsself/itself/

You might also want to mention the not presenting properly having to do with the area of the window being small.
Attachment #497927 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 28

7 years ago
http://hg.mozilla.org/mozilla-central/rev/e435c9812855
Status: NEW → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 603793
Verified fixed for me in [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre].
Status: RESOLVED → VERIFIED

Comment 31

7 years ago
Sorry, still not working for me in: [Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre]

Comment 32

7 years ago
(In reply to comment #31)
> Sorry, still not working for me in: [Mozilla/5.0 (Windows NT 6.1; Win64; x64;
> rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre]

In the fix posted by Jeff (2010-12-15 16:24:28 PST), the comment states that it's an issue on Nvidia hardware. However I'm seeing the issue still on a ATI Radeon HD 3600 Series.
Truth, please file a new bug and add the graphic information from the troubleshooting page in the comment. Thanks.
Target Milestone: --- → mozilla2.0b9
Wait. Lets reopen bug 603793 in that case. Haven't seen that your bug has been duped.

Updated

7 years ago
Duplicate of this bug: 614846

Comment 36

7 years ago
The evidence suggests drivers were at fault for me too. 

This ticket's symptoms (and quite different ones with the whole window - bug 614846) aren't present for me in last night's build (2010-12-22), so I assume the patch here did the trick. 

I then upgraded nvidia drivers and found these 2 issues went away in 4.0b8 too. 
 - NVIDIA GeForce GTX 260 
 - old driver: 8.17.11.9745, date 4-3-2010
 - new driver: 8.17.12.5896, date 7-9-2010 

Thanks all.
You need to log in before you can comment on or make changes to this bug.