Closed Bug 613985 Opened 9 years ago Closed 7 years ago

release_sanity.py should verify that all required repos are tagged

Categories

(Release Engineering :: Release Automation: Other, defect, P5)

All
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bhearsum, Unassigned)

References

Details

(Whiteboard: [automation])

The 0.8.0 automation requires that buildbot-configs, buildbotcustom, compare-locales, and tools are all tagged with the _RELEASE and _BUILDn tags. release_sanity.py should verify this.
Priority: -- → P5
(In reply to Ben Hearsum [:bhearsum] from comment #0)
> The 0.8.0 automation requires that buildbot-configs, buildbotcustom,
> compare-locales, and tools are all tagged with the _RELEASE and _BUILDn
> tags. release_sanity.py should verify this.

Now, only buildbot-configs, buildbotcustom, and tools are required to be tagged prior to the automation starting. To do this, we should add a method similar to the 'verify_repo' one in release_sanity.py, and have it called towards the start of the checks, maybe around here: http://hg.mozilla.org/build/tools/file/default/buildbot-helpers/release_sanity.py#l362. It needs to be called 3 times, once for each repository that we're checking.
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: hg-automation
Duplicate of this bug: 725297
Duplicate of this bug: 764126
I don't think this is worthwhile in the release kickoff world, because this tagging is automated.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.