Closed Bug 614073 Opened 11 years ago Closed 10 years ago

About:support doesn't give proper graphics card vendor/device data

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 678330

People

(Reporter: christian, Unassigned)

References

(Blocks 1 open bug)

Details

I was checking about:support for my graphics card and get the following:


Adapter Description: 0x22600,0x20400
Vendor ID: 2600
Device ID: 2600
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled: false
DirectWrite Enabled: false
GPU Accelerated Windows: 1/1 OpenGL

I would expect the description, vendor, and device id to be found/mapped. Here is the output from system profiler:

NVIDIA GeForce 9400M:

  Chipset Model:	NVIDIA GeForce 9400M
  Type:	GPU
  Bus:	PCI
  VRAM (Total):	256 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0863
  Revision ID:	0x00b1
  ROM Revision:	3427
Version: unspecified → Trunk
I see the same on my MacBook Pro. For me it looks like this: http://img718.imageshack.us/img718/9559/graphicq.jpg
If I compare this with the values from the OS X system profiler, than the
vendor ID should be 0x10de and not 0000. And the Device ID should also not be
0000, it should be 0x08a0. The RAM should be 256 MB.
I am having the same issue on a 1st gen Mac Pro. The difference is I am not getting any accelerated window:

Adapter Description: 0x22400,0x20400
Vendor ID: 0000
Device ID: 0000
Adapter RAM:
Adapter Drivers:
Driver Version:
Driver Date:
Direct2D Enabled: false
DirectWrite Enabled: false
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce 7300 GT OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows: 0/1
This was fixed by bug 678330.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678330
You need to log in before you can comment on or make changes to this bug.