The default bug view has changed. See this FAQ.

Use IOKit to get precise GPU information in GfxInfo on Mac

RESOLVED FIXED in mozilla10

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
mozilla10
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Currently we use CGL to get GPU information, which is very vague. For example, for NVIDIA cards, it only tells whether the card is a Geforce 8 or newer, or not.

We need to switch to using IOKit like Chrome does: bug 678053 comment 3:

"We use IOKit to scan for PCI-based GPUs.

See http://src.chromium.org/viewvc/chrome/trunk/src/content/gpu/gpu_info_collector_mac.mm?view=markup "

Once this is done, we can stop blacklisting all Geforce 7 and older cards (bug 678053) and only blacklist the cards known to have issues (Geforce 7300 GT).
(Reporter)

Updated

6 years ago
Blocks: 678053
Created attachment 561598 [details] [diff] [review]
Use IOKit some
Attachment #561598 - Flags: review?(bjacob)
This patch borrows some of the code from Chromium. It doesn't try to detect dual GPU situations and assumes that CGDisplayIOServicePort(kCGDirectMainDisplay) will do the correct thing. This assumption is supported by testing.
Blocks: 687868
(Reporter)

Updated

6 years ago
Attachment #561598 - Flags: review?(bjacob) → review+
https://hg.mozilla.org/mozilla-central/rev/d747526bd066
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10

Updated

5 years ago
Duplicate of this bug: 614073
You need to log in before you can comment on or make changes to this bug.