Last Comment Bug 614382 - Polish the Edit filter dialog on Mac and also fix some obsolete styles (all OS)
: Polish the Edit filter dialog on Mac and also fix some obsolete styles (all OS)
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Themes (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1b2
Assigned To: Stefan [:stefanh]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-23 13:37 PST by Stefan [:stefanh]
Modified: 2010-12-27 10:37 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1.0 (10.64 KB, patch)
2010-11-30 14:40 PST, Stefan [:stefanh]
no flags Details | Diff | Review
v1.1 (10.05 KB, patch)
2010-12-23 10:18 PST, Stefan [:stefanh]
mnyromyr: review+
Details | Diff | Review

Description Stefan [:stefanh] 2010-11-23 13:37:41 PST
Basically the same issues as in bug 613358 (mac styling, some obsolete rules)
Comment 1 Stefan [:stefanh] 2010-11-30 14:40:08 PST
Created attachment 494171 [details] [diff] [review]
v1.0

Just putting it here, need to think a bit about this since it might be an idea to move the .small-button rules to a file that both dialogs (search and filter) can use.

The width of the dialog was hardcoded in the css files, even though we set a width in the xul file (doesn't seem like a good idea either, though). The height is wrong for mac, since there's no room for a scrollbar in the upper listbox, but I figured that it can go in another bug.
Comment 2 Stefan [:stefanh] 2010-12-23 10:18:22 PST
Created attachment 499534 [details] [diff] [review]
v1.1

-#FilterEditor {
-  width: 560px;
-  min-height:1px;

Not sure why the min-height was there...

Also see bug 620797, button rules are the same here.
Comment 3 Karsten Düsterloh 2010-12-26 13:52:48 PST
Comment on attachment 499534 [details] [diff] [review]
v1.1

I'm not sure I mentioned that in the search reviews - probably not, because this patch here has the same problem:
if you tab through the dialog, the keyboard focus gets lost (invisible) twice:
- leaving "match" radio group, entering rules area
- leaving rules area, entering actions area

The problem is that the areas themselves get the focus before tabbing gets to their internal elements, so either the area frames should provide visual feedback or (better!) they should not be part of the tab order.

Apart from that, the patch looks fine.
Comment 4 Stefan [:stefanh] 2010-12-26 14:32:22 PST
(In reply to comment #3)
> Comment on attachment 499534 [details] [diff] [review]
> v1.1
> 
> I'm not sure I mentioned that in the search reviews - probably not, because
> this patch here has the same problem:
> if you tab through the dialog, the keyboard focus gets lost (invisible) twice:
> - leaving "match" radio group, entering rules area
> - leaving rules area, entering actions area

This happens on 2.0.11 too, so it's not caused by the patch. Perhaps we could have a separate bug for it?
Comment 5 Karsten Düsterloh 2010-12-27 10:17:42 PST
Comment on attachment 499534 [details] [diff] [review]
v1.1

Moved the tabbing issue out to bug 621546.
Comment 6 Stefan [:stefanh] 2010-12-27 10:37:59 PST
http://hg.mozilla.org/comm-central/rev/8f113735d48c

Note You need to log in before you can comment on or make changes to this bug.