Last Comment Bug 620797 - [Mac Default] - Use a better focus ring colour in MailNews search dialog
: [Mac Default] - Use a better focus ring colour in MailNews search dialog
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Themes (show other bugs)
: Trunk
: x86 Mac OS X
: -- minor (vote)
: seamonkey2.1b2
Assigned To: Stefan [:stefanh]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-21 14:54 PST by Stefan [:stefanh]
Modified: 2010-12-27 10:38 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Use -moz-mac-focusring (2.10 KB, patch)
2010-12-23 08:17 PST, Stefan [:stefanh]
mnyromyr: review+
Details | Diff | Review

Description Stefan [:stefanh] 2010-12-21 14:54:28 PST
Now that bug 615589 is fixed, we can use the system focus ring colour.
Comment 1 Stefan [:stefanh] 2010-12-23 08:17:50 PST
Created attachment 499520 [details] [diff] [review]
Use -moz-mac-focusring

I simplified the style rules a bit - I think this is more manageable. I don't know if it's worth it - but we could put the button rules in a shared css file since the same buttons appear in messenger/filterDialog.css (see bug 614382).
Comment 2 Karsten Düsterloh 2010-12-26 14:10:02 PST
Comment on attachment 499520 [details] [diff] [review]
Use -moz-mac-focusring

The patch has a similar tabbing problem as in bug 614382:
if you tab from the match radio group to the search criteria area, the keyboard focus gets lost (invisible) in between, because the area frame is part of the tab order. Either the area frame needs to give visual feedback or (better!) it should not be part of the tabbing order.

The rest of the patch looks fine!
Comment 3 Stefan [:stefanh] 2010-12-26 14:28:19 PST
(In reply to comment #2)
> Comment on attachment 499520 [details] [diff] [review]
> Use -moz-mac-focusring
> 
> The patch has a similar tabbing problem as in bug 614382:
> if you tab from the match radio group to the search criteria area, the keyboard
> focus gets lost (invisible) in between, because the area frame is part of the
> tab order. Either the area frame needs to give visual feedback or (better!) it
> should not be part of the tabbing order.

How is this related to the patch? I'm only changing the focus ring colour...
Comment 4 Karsten Düsterloh 2010-12-26 15:08:59 PST
Comment on attachment 499520 [details] [diff] [review]
Use -moz-mac-focusring

Oops, I confused this with bug 613358.
I'll file a new bug for the regression.
Comment 5 Karsten Düsterloh 2010-12-26 15:58:48 PST
Filed bug 621468.
Not a regression, though.
Comment 6 Stefan [:stefanh] 2010-12-27 10:38:24 PST
http://hg.mozilla.org/comm-central/rev/e556242a36ef

Note You need to log in before you can comment on or make changes to this bug.