If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Explanation of "reply to" field would be helpful

RESOLVED FIXED in Thunderbird 9.0

Status

Thunderbird
Account Manager
--
minor
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Joshua Pancer, Assigned: jyeo)

Tracking

unspecified
Thunderbird 9.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Build Identifier: 3.1.6

The manage identities>Edit Identity> "Reply to address" section should have a note saying "Leave this blank unless you explicitly want email replies to go to a different address".

Reproducible: Always




I haven't been able to figure out why my name hasn't been appearing in replies I get and deleting the "reply to" address altogether fixed the problem!
Bryan thoughts ?
Seems like a good idea, I assume lots of people fill this in for the wrong reasons.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good first bug]
(Assignee)

Comment 3

6 years ago
Created attachment 556744 [details] [diff] [review]
614407#1.patch
Attachment #556744 - Flags: ui-review?(bwinton)
Attachment #556744 - Flags: review?(dbienvenu)
(Assignee)

Updated

6 years ago
Attachment #556744 - Attachment description: edited the following files: → edited the following files: +++ b/mail/locales/en-US/chrome/messenger/am-main.dtd +++ b/mailnews/base/prefs/content/am-identity-edit.xul +++ b/mailnews/base/prefs/content/am-main.xul +++ b/suite/locales/en-US/chrome/mailnews/pref/am-main.dtd
(Assignee)

Updated

6 years ago
Attachment #556744 - Attachment description: edited the following files: +++ b/mail/locales/en-US/chrome/messenger/am-main.dtd +++ b/mailnews/base/prefs/content/am-identity-edit.xul +++ b/mailnews/base/prefs/content/am-main.xul +++ b/suite/locales/en-US/chrome/mailnews/pref/am-main.dtd → 614407#1.patch
Attachment #556744 - Attachment filename: replyToPatch → 614407#1.patch
Comment on attachment 556744 [details] [diff] [review]
614407#1.patch

I think it's better, my only complaint is that it sounds a little like we're going to send all replies the user sends to that address, instead of asking other people to send replies to the user to a different address.

The text "Ask other people to reply to this other address" also seems to fit, and is closer to what I think we're trying to say, but I'm happy to hear more suggestions.  :)

ui-r=me with the new text.

Thanks,
Blake.
Attachment #556744 - Flags: ui-review?(bwinton) → ui-review+
(Assignee)

Comment 5

6 years ago
> The text "Ask other people to reply to this other address" also seems to
> fit, and is closer to what I think we're trying to say, but I'm happy to
> hear more suggestions.  :)

current:
"send email replies to this address"

how about these:
"Recipients will send replies to this address"
"Your recipients will reply to this address" 
"Your recipients will send replies to this address"
"Recipients will reply to this address" (i prefer this, it's shorter)
"Recipients will reply to this other address"
"Your recipients will reply to this other address"
(In reply to Jason(:jyeo) from comment #5)
> "Recipients will reply to this address" (i prefer this, it's shorter)

It is shorter, but I think it still suffers some of the confusion about potentially being the same as their regular address, which is why I would prefer:

> "Recipients will reply to this other address"

(I'm also assigning this to you, cause it looks like you're the one who'll fix it.  :)

Thanks,
Blake.
Assignee: nobody → jasonyeo88
Status: NEW → ASSIGNED

Comment 7

6 years ago
Comment on attachment 556744 [details] [diff] [review]
614407#1.patch

thx for the patch
Attachment #556744 - Flags: review?(dbienvenu) → review+

Updated

6 years ago
Keywords: checkin-needed
(Assignee)

Comment 8

6 years ago
Created attachment 557734 [details] [diff] [review]
bug614407#2.patch
Attachment #556744 - Attachment is obsolete: true
Attachment #557734 - Flags: ui-review?(bwinton)
Attachment #557734 - Flags: review?(dbienvenu)
(Assignee)

Comment 9

6 years ago
Comment on attachment 557734 [details] [diff] [review]
bug614407#2.patch

i've changed the text to Recipients will reply to this other address, as requested by blake. :)
Attachment #557734 - Attachment description: i've changed the text as requested by blake → bug614407#2.patch
Comment on attachment 557734 [details] [diff] [review]
bug614407#2.patch

r+ from bienvenu and ui-r+ from bwinton (with the change in wording done in this patch) carried over.
Attachment #557734 - Flags: ui-review?(bwinton)
Attachment #557734 - Flags: ui-review+
Attachment #557734 - Flags: review?(dbienvenu)
Attachment #557734 - Flags: review+
Checked in: http://hg.mozilla.org/comm-central/rev/814036585e36

Thanks Jason.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
You need to log in before you can comment on or make changes to this bug.