Tabs scattered all over the place when entering Panorama

VERIFIED FIXED in Firefox 4.0b10

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: Ehsan, Assigned: ttaubert)

Tracking

Trunk
Firefox 4.0b10
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [softblocker])

Attachments

(1 attachment)

When I tried to enter Panorama today, this is what I saw: http://grab.by/7yr2

Exiting and reentering Panorama just brings me to the exact same screen.  I didn't see anything on the error console.

Is this known?
blocking2.0: --- → ?
Did you restore a session? And is this on B7 or a current nightly?
This is a current nightly, built from http://hg.mozilla.org/mozilla-central/rev/4d73807bfec7.

I always restore my session, but I last restarted my browser late last night or early this morning, IIRC, and have been heavily using it.

I tried grabbing the resizers at the bottom edge of the Mozilla, Travel, and the unnamed group (the big one at the center) to make them a few (maybe around 10) pixels bigger in each dimension, and right when resizing all of the tabs belonging to each group fell into their proper spot.  This is what I'm seeing now:

http://grab.by/7yrv

So I think the code responsible for figuring out whether each group is big enough for its tabs had somehow choked in the middle of its thing.

I wasn't paying close attention when I first entered Panorama, but I _think_ that the tabs were animating in seemingly random directions and they suddenly stopped.  But take this comment with a grain of salt (you'll be relying on my memory after all!!!)
(In reply to comment #0)
> When I tried to enter Panorama today, this is what I saw: http://grab.by/7yr2
> 
> Exiting and reentering Panorama just brings me to the exact same screen.  I
> didn't see anything on the error console.
> 
> Is this known?

Off the top of my head, this looks more like an issue with restoring and placing the tabs while not yet having proper group information. The fact that you could jiggle the group bounds, forcing an .arrange(), and it worked, means that the shouldStack() and group info ultimately are working... it just seems like maybe it didn't have access to the group info right when you first launched panorama.

Did you launch Panorama right after startup?
(In reply to comment #3)
> (In reply to comment #0)
> > When I tried to enter Panorama today, this is what I saw: http://grab.by/7yr2
> > 
> > Exiting and reentering Panorama just brings me to the exact same screen.  I
> > didn't see anything on the error console.
> > 
> > Is this known?
> 
> Off the top of my head, this looks more like an issue with restoring and
> placing the tabs while not yet having proper group information. The fact that
> you could jiggle the group bounds, forcing an .arrange(), and it worked, means
> that the shouldStack() and group info ultimately are working... it just seems
> like maybe it didn't have access to the group info right when you first
> launched panorama.

That seems plausible, indeed.

> Did you launch Panorama right after startup?

No, quite a while after startup in fact.
wondering if this could be somehow related to setting >browser.sessionstore.max_concurrent_tabs< to 0, as all the screenshots in this bug, as well as my own[1] don't show any tab-previews.


[1] http://grab.by/7D9S
Blocks: 598154
OS: Mac OS X → Windows XP
Priority: -- → P2
blocking2.0: ? → betaN+
Assignee: nobody → ddahl
bugspam (moving b9 to b10)
Blocks: 608028
bugspam (removing b9)
No longer blocks: 598154
Does this still happen? We've landed some better session store integration recently... I wonder if this might be fixed.
Keywords: qawanted
can confirm that the _scattering_ is fixed.

however this http://grab.by/8k9A does still happen, wondering if this is related?
The scattering seems to always happen in case, before you enter Panorama and after restoring a saved session, you resize the Firefox window smaller than it was when you saved the session.  I'm still getting it on the 2011-01-11 nightly (only tested on Mac OS X 10.6).

When you enter Panorama, groups get resized to fit the current window size, while tab thumbnails are kept in their original position.  Once switching to a group by clicking on one of the thumbnails, all the tabs for that group get redrawn inside the group bounds.  Tabs get also redrawn in the correct position by resizing the Firefox window when in Panorama.

I originally thought it was due to incompatibilities with the BarTab extension, but a restart without BarTab proved me wrong, as it still happened.  In my case, browser.sessionstore.max_concurrent_tabs is set to the default value (3).

http://img89.imageshack.us/img89/1667/screenshot20110111at102.png

I also occasionally get something similar to what shown in Comment #10.

By the way, why was Platform set to x86 Windows XP?  All the screenshots I see on this bug appear to have been taken on Mac OS.
(In reply to comment #10)
> can confirm that the _scattering_ is fixed.
> 
> however this http://grab.by/8k9A does still happen, wondering if this is
> related?

Thanks Matthias. This particular thing, I believe, will be fixed with bug 622835.
OS: Windows XP → All
Hardware: x86 → All
(In reply to comment #11)
> The scattering seems to always happen in case, before you enter Panorama and
> after restoring a saved session, you resize the Firefox window smaller than it
> was when you saved the session.

Ah. If this is the only way to reproduce this, though, it may be fixed by bug 601534.

> By the way, why was Platform set to x86 Windows XP?  All the screenshots I see
> on this bug appear to have been taken on Mac OS.

Thanks. Fixed.
Whiteboard: [softblocker]
(In reply to comment #13)
> (In reply to comment #11)
> > The scattering seems to always happen in case, before you enter Panorama and
> > after restoring a saved session, you resize the Firefox window smaller than it
> > was when you saved the session.
> 
> Ah. If this is the only way to reproduce this, though, it may be fixed by bug
> 601534.

We shouldn't wait for that bug though.

David, are you working on this, or should someone else take it?
Someone can take it.
Assignee: ddahl → nobody
Duplicate of this bug: 614820
(In reply to comment #14)
> > Ah. If this is the only way to reproduce this, though, it may be fixed by bug
> > 601534.
> 
> We shouldn't wait for that bug though.

Indeed. We just punted on 601534.
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Depends on: 624953
No longer depends on: 601534
This is fixed when patch for bug 624953 lands.
softblocker = critical
Severity: normal → critical
Severity: critical → normal
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
verified with nightly build of minefield.
Status: RESOLVED → VERIFIED
Keywords: qawanted
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.