Search variance on application for the Add-on 'Add-on Compatibility Reporter'

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Search
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Details

(Whiteboard: [mozmill][mozmill-test-failure])

(Reporter)

Description

7 years ago
Currently, when one changes the following preference [1] from its default value of using addons.mozilla.org to the preview site at addons.allizom.org, so the preference value becomes [2], the add-on can not be found on Firefox 3.5 and Firefox 3.6 -- but not Minefield.  

The query [3] returns the add-on through the site.

This currently affects a Mozmill test [4] for Firefox 3.5 and 3.6 where we try to search this add-on through the Add-on manager to install it, but it is not found.

[1] extensions.getAddons.search.url

[2] https://addons.allizom.org/%LOCALE%/%APP%/api/%API_VERSION%/search/%TERMS%/all/10/%OS%/%VERSION%

[3] https://addons.allizom.org/en-US/firefox/search/?q=Add-on%20Compatibility%20Reporter

[4] http://hg.mozilla.org/qa/mozmill-tests/file/8530a6bbf1b0/firefox/restartTests/testExtensionInstallGetAddons/test1.js
(Reporter)

Comment 1

7 years ago
Forgot to mention, the query used is 'Add-on Compatibility Reporter' and what is returned is a single result for the Add-on 'Crash Report Helper'. The second add-on listed of the query https://addons.allizom.org/en-US/firefox/search/?q=Add-on%20Compatibility%20Reporter.
(Reporter)

Comment 2

7 years ago
I dont know if search is the best component for this, please move if necessary.
It doesn't only happen on allizom, but also when performing a search from within the addons manager without the preferences modified. There is no result reportered back.
I see a result when searching in Minefield and I see the add-on in the API results. Any chance you already have that add-on installed?
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> I see a result when searching in Minefield and I see the add-on in the API
> results. Any chance you already have that add-on installed?

As I indicated, this is with Namoroka and Shiretoko, where the variance in the search is visible. When changing the preference to the preview site, 'allizom', I am unable to retrieve the Add-on as a result through searching in the old manager. It is visible through the query below, and I'm using a same query in the old manager. Compatibility is good 'Firefox 3.5 - 4.0b8pre'. The Add-on is not installed.

https://addons.allizom.org/en-US/firefox/search/?q=Add-on%20Compatibility%20Reporter
(Reporter)

Comment 6

7 years ago
Dave, will you be able to further investigate this? Anyone else?

Henrik, if this lingers, would you propose we switch the tests to locate another available add-on?
Justin, is it anything your group can check/fix in a short term? Not sure if this could be a regression in an upcoming AMO version.
The failure has been started with out test-run on 2010/11/17 . Means it could be the cause of a check-in between 2010/11/16 and 2010/11/17:

http://mozmill-release.brasstacks.mozilla.com/#/general/failure?branch=3.6&platform=Mac&from=2010-11-01&to=2010-12-07&test=firefox%2FrestartTests%2FtestExtensionInstallGetAddons%2Ftest1.js&func=testInstallExtension
Assignee: nobody → dd
I'll investigate this.
Is this still a bug on addons-dev.allizom.org?
Assignee: dd → nobody
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.