Last Comment Bug 615001 - Fix readPixels (pass the gl-enums-test.html test)
: Fix readPixels (pass the gl-enums-test.html test)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 12:58 PST by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-01-13 14:54 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix readpixels (1.67 KB, patch)
2010-11-26 12:59 PST, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2010-11-26 12:58:37 PST
We had some weird code in there, making us fail that test.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2010-11-26 12:59:02 PST
Created attachment 493454 [details] [diff] [review]
fix readpixels
Comment 2 Vladimir Vukicevic [:vlad] [:vladv] 2010-11-29 15:06:06 PST
Comment on attachment 493454 [details] [diff] [review]
fix readpixels

erm wait, I just added that code in bug 612336  (was checked in with wrong bug #).  We have to synthesize INVALID_OPERATION if both format and type are invalid; the test even says:

  // note that the GL error is INVALID_OPERATION if both format and type are invalid, but INVALID_ENUM if only one is.

Need to update our copy of the test suite with latest from svn again looks like.
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2010-12-06 08:24:14 PST
ok, closing.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2010-12-07 11:12:43 PST
We're still failing this test (from svn). Also, it doesn't seem to have anymore the comment that you were referring to:

https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/tests/conformance/gl-enum-tests.html

Moreover I can't see where in the WebGL or GL ES spec it would prescribe this behavior. It seems to me that at some point in the past this test was wrong, and has been fixed since.
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2012-01-13 14:54:47 PST
This test is now passing on all platform on the build slaves.

Note You need to log in before you can comment on or make changes to this bug.