Closed Bug 615145 Opened 10 years ago Closed 10 years ago

Incorrect placement of the KASRA, FATHA and DAMMA characters on Windows 7

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 615121
Tracking Status
blocking2.0 --- final+

People

(Reporter: ehsan, Assigned: jfkthame)

References

()

Details

(Keywords: intl, regression, testcase)

See the test case, for example.  The position of the KASRA, FATHA, and DAMMA characters is incorrect on Windows 7.  The test case in the URL field demonstrates this problem for KASRA (screenshot: http://grab.by/7CB2).  See the screenshot from the same page on OS X for comparison: http://grab.by/7CB3.

This page, for example, shows the mis-positioning for all of the three characters:

<http://ar.wikipedia.org/wiki/%D8%B3%D9%88%D8%B1%D8%A9_%D8%A7%D9%84%D9%81%D8%A7%D8%AA%D8%AD%D8%A9#.D9.85.D8.AD.D9.88.D8.B1_.D9.85.D9.88.D8.A7.D8.B6.D9.8A.D8.B9_.D8.A7.D9.84.D8.B3.D9.88.D8.B1.D8.A9>

(example for DAMMA: http://grab.by/7CBg, example for FATHA: http://grab.by/7CBj)

This might be a bug related to Harfbuzz, so I'm CCing Behdad as well.
blocking2.0: --- → ?
Don't think so.  Which font?  I let Jonathan figure out :).
Assignee: nobody → jfkthame
blocking2.0: ? → final+
(In reply to comment #1)
> Don't think so.  Which font?  I let Jonathan figure out :).

Don't worry, Behdad, it's our bug - not yours! :)

See bug 615121, where the required patch is already waiting to land.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615121
oh, operator precedence.  Only one of the many reason why I _love_ C/C++...
You need to log in before you can comment on or make changes to this bug.