Multipart email with Content-Type: text/plain; charset="iso-8859-1" improperly displayed starting with 3.3 series

RESOLVED DUPLICATE of bug 594646

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 594646
7 years ago
2 years ago

People

(Reporter: protz, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 493656 [details]
The faulty email

See attached email and attached screenshots. The email used to display fine in 3.1, now it looks like utf8 is badly interpreted as latin1. The email DOES announce latin1 though, so I don't really know what's wrong here.

Ideas? View > Character Encoding is set as ISO-8859-1. Setting it to UTF8 is even worse.
(Reporter)

Comment 1

7 years ago
Created attachment 493657 [details]
3.3
(Reporter)

Comment 2

7 years ago
Created attachment 493658 [details]
3.1 (good)
OS: Linux → All
Hardware: x86_64 → All

Comment 3

7 years ago
WFM
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101129 Thunderbird/3.3a2pre

Comment 4

7 years ago
Set html5.enable to "false" as a work-around.
I have a similar bug filed, I'll search for it later
(Reporter)

Comment 6

7 years ago
Submitted a patch in bug 594646 that fixes the issue I described in this bug report. Marking as duplicate, will reopen if not a duplicate.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594646
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.