Last Comment Bug 615223 - Webpages loaded in the parent process (about:credits and UI-based iframes) fail to load [JavaScript component does not have a method named: 'available' when calling method: nsIInputStream::available]
: Webpages loaded in the parent process (about:credits and UI-based iframes) fa...
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 8
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
Mentors:
: 622365 655790 (view as bug list)
Depends on:
Blocks: 624345
  Show dependency treegraph
 
Reported: 2010-11-29 08:07 PST by Anna (Waverley)
Modified: 2011-12-15 15:51 PST (History)
15 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (921 bytes, patch)
2011-06-01 11:41 PDT, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
mark.finkle: review+
Details | Diff | Splinter Review

Description Anna (Waverley) 2010-11-29 08:07:11 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101119 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre Fennec /4.0b3pre

Open remote page from another remote page with Browser.tabs.remote set to false fails

Reproducible: Always

Steps to Reproduce:
1. go to about:config
2. find browser.tabs.remote
3. set the browser.tabs.remote to false
4. restart the web browser
5. go to url: http://www.google.com


Actual Results:  
The webpage doesn't load.

Expected Results:  
The webpage should load.

Note: 

TC in Litmus: https://litmus.mozilla.org/show_test.cgi?id=12961

Please also have a look at: https://litmus.mozilla.org/show_test.cgi?id=12960
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-29 08:29:24 PST
Using a Linux desktop debug build, I see:

[Exception... "'JavaScript component does not have a method named: "available"' when calling method: [nsIInputStream::available]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]

Which happens here:

http://mxr.mozilla.org/mozilla-central/source/xpcom/io/nsMultiplexInputStream.cpp#199
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-29 10:45:48 PST
The requestBody here:

http://mxr.mozilla.org/mozilla-central/source/netwerk/protocol/http/nsHttpTransaction.cpp#295

Seems to be an XPCWrappedJSObject
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-29 10:52:48 PST
Breakpoint 2, nsMultiplexInputStream::AppendStream (this=0x7fffd423fa00, aStream=0x7fffd41fdd80) at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom io/nsMultiplexInputStream.cpp:128

#0  nsMultiplexInputStream::AppendStream (this=0x7fffd423fa00, aStream=0x7fffd41fdd80)
    at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom/io/nsMultiplexInputStream.cpp:128
#1  0x00007ffff402514c in nsHttpTransaction::Init (this=0x7fffd424a400, caps=1 '\001', cinfo=0x7fffd423f640, requestHead=0x7fffd69484e0, 
    requestBody=0x7fffd41fdd80, requestBodyHasHeaders=1, target=0x7fffeb0e88c0, callbacks=0x7fffd42552b0, eventsink=0x7fffd69485a0, 
    responseBody=0x7fffffffd430) at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpTransaction.cpp:295
#2  0x00007ffff403a666 in nsHttpChannel::SetupTransaction (this=0x7fffd6948400)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:667
#3  0x00007ffff4038db8 in nsHttpChannel::Connect (this=0x7fffd6948400, firstTime=0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:318
#4  0x00007ffff4040bf2 in nsHttpChannel::OnNormalCacheEntryAvailable (this=0x7fffd6948400, aEntry=0x7fffd423fac0, aAccess=2, aEntryStatus=0, 
    aIsSync=0) at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:2275
#5  0x00007ffff40495d2 in nsHttpChannel::OnCacheEntryAvailable (this=0x7fffd6948400, entry=0x7fffd423fac0, access=2, status=0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:4471
#6  0x00007ffff3fc9602 in nsCacheListenerEvent::Run (this=0x7fffd4255820)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/cache/nsCacheService.cpp:1441
#7  0x00007ffff571ff21 in nsThread::ProcessNextEvent (this=0x7fffeb0e88c0, mayWait=0, result=0x7fffffffd87c)
    at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom/threads/nsThread.cpp:626
#8  0x00007ffff56a2fc8 in NS_ProcessNextEvent_P (thread=0x7fffeb0e88c0, mayWait=0) at nsThreadUtils.cpp:250
#9  0x00007ffff54d8214 in mozilla::ipc::MessagePump::Run (this=0x7fffe5a23900, aDelegate=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/glue/MessagePump.cpp:110
#10 0x00007ffff578efcd in MessageLoop::RunInternal (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:219
#11 0x00007ffff578ef52 in MessageLoop::RunHandler (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:202
#12 0x00007ffff578eee3 in MessageLoop::Run (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:176
#13 0x00007ffff5357c1b in nsBaseAppShell::Run (this=0x7fffe24a1800)
    at /home/mfinkle/source/mozilla-trunk/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:181
#14 0x00007ffff5097519 in nsAppStartup::Run (this=0x7fffe25b90b0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:191
#15 0x00007ffff3ee6269 in XRE_main (argc=1, argv=0x7fffffffe348, aAppData=0x7fffeb029080)
    at /home/mfinkle/source/mozilla-trunk/mozilla/toolkit/xre/nsAppRunner.cpp:3691
#16 0x0000000000401ea2 in main (argc=1, argv=0x7fffffffe348) at /home/mfinkle/source/mozilla-trunk/mozilla/mobile/app/nsBrowserApp.cpp:155
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-29 10:53:53 PST
Breakpoint 1, nsMultiplexInputStream::Available (this=0x7fffd423fa00, _retval=0x7fffd424a480) at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom/io/nsMultiplexInputStream.cpp:190

#0  nsMultiplexInputStream::Available (this=0x7fffd423fa00, _retval=0x7fffd424a480)
    at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom/io/nsMultiplexInputStream.cpp:190
#1  0x00007ffff3f2d6ed in nsBufferedInputStream::Available (this=0x7fffd42aae60, result=0x7fffd424a480)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/base/src/nsBufferedStreams.cpp:316
#2  0x00007ffff4025256 in nsHttpTransaction::Init (this=0x7fffd424a400, caps=1 '\001', cinfo=0x7fffd423f640, requestHead=0x7fffd69484e0, 
    requestBody=0x7fffd41fdd80, requestBodyHasHeaders=1, target=0x7fffeb0e88c0, callbacks=0x7fffd42552b0, eventsink=0x7fffd69485a0, 
    responseBody=0x7fffffffd430) at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpTransaction.cpp:308
#3  0x00007ffff403a666 in nsHttpChannel::SetupTransaction (this=0x7fffd6948400)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:667
#4  0x00007ffff4038db8 in nsHttpChannel::Connect (this=0x7fffd6948400, firstTime=0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:318
#5  0x00007ffff4040bf2 in nsHttpChannel::OnNormalCacheEntryAvailable (this=0x7fffd6948400, aEntry=0x7fffd423fac0, aAccess=2, aEntryStatus=0, 
    aIsSync=0) at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:2275
#6  0x00007ffff40495d2 in nsHttpChannel::OnCacheEntryAvailable (this=0x7fffd6948400, entry=0x7fffd423fac0, access=2, status=0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/protocol/http/nsHttpChannel.cpp:4471
#7  0x00007ffff3fc9602 in nsCacheListenerEvent::Run (this=0x7fffd4255820)
    at /home/mfinkle/source/mozilla-trunk/mozilla/netwerk/cache/nsCacheService.cpp:1441
#8  0x00007ffff571ff21 in nsThread::ProcessNextEvent (this=0x7fffeb0e88c0, mayWait=0, result=0x7fffffffd87c)
    at /home/mfinkle/source/mozilla-trunk/mozilla/xpcom/threads/nsThread.cpp:626
#9  0x00007ffff56a2fc8 in NS_ProcessNextEvent_P (thread=0x7fffeb0e88c0, mayWait=0) at nsThreadUtils.cpp:250
#10 0x00007ffff54d8214 in mozilla::ipc::MessagePump::Run (this=0x7fffe5a23900, aDelegate=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/glue/MessagePump.cpp:110
#11 0x00007ffff578efcd in MessageLoop::RunInternal (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:219
#12 0x00007ffff578ef52 in MessageLoop::RunHandler (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:202
#13 0x00007ffff578eee3 in MessageLoop::Run (this=0x7fffe5a0f6a0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/ipc/chromium/src/base/message_loop.cc:176
---Type <return> to continue, or q <return> to quit---
#14 0x00007ffff5357c1b in nsBaseAppShell::Run (this=0x7fffe24a1800)
    at /home/mfinkle/source/mozilla-trunk/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:181
#15 0x00007ffff5097519 in nsAppStartup::Run (this=0x7fffe25b90b0)
    at /home/mfinkle/source/mozilla-trunk/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:191
#16 0x00007ffff3ee6269 in XRE_main (argc=1, argv=0x7fffffffe348, aAppData=0x7fffeb029080)
    at /home/mfinkle/source/mozilla-trunk/mozilla/toolkit/xre/nsAppRunner.cpp:3691
#17 0x0000000000401ea2 in main (argc=1, argv=0x7fffffffe348) at /home/mfinkle/source/mozilla-trunk/mozilla/mobile/app/nsBrowserApp.cpp:155
Comment 5 Doug Turner (:dougt) 2010-12-01 10:46:17 PST
jason, this sounds wrong.  I do not think this should block (cause we aren't shipping that way), but is this something you want to look at?
Comment 6 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-01-04 05:10:00 PST
*** Bug 622365 has been marked as a duplicate of this bug. ***
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-01-10 06:40:56 PST
This is affecting some pages, like about:credits, which load web pages into local tabs. see bug 624345.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-09 12:39:38 PDT
*** Bug 655790 has been marked as a duplicate of this bug. ***
Comment 9 Jason Duell [:jduell] (needinfo me) 2011-05-09 16:26:03 PDT
Are we still supporting browser.tabs.remote?  Is that some single process version of fennec I haven't heard about?

Also, comment 7 implies browser.tabs.remove is set to 0 for about:credits?  I thought it was a global setting.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-09 16:39:36 PDT
"browser.tabs.remote" is a global setting and is set to true, but since "about:credits" is an "about:" page it is loaded into a non-e10s browser. Also, "about:credits" opens http;// content, not chrome:// content, so the error occurs.
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-10 13:45:58 PDT
We need this for about:credits type pages and UI-base iframes (UI loaded from the Web)
Comment 12 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-06-01 11:41:00 PDT
Created attachment 536680 [details] [diff] [review]
Patch

One liner
Comment 13 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-01 11:48:59 PDT
Comment on attachment 536680 [details] [diff] [review]
Patch

Ugh!
Comment 14 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-01 11:49:31 PDT
try for aurora too
Comment 15 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-06-03 04:10:38 PDT
m-c changeset:
http://hg.mozilla.org/mozilla-central/rev/e36cf5419cbf

Still need to push it to aurora but need approval first.
Comment 16 Andreea Pod 2011-07-13 07:18:26 PDT
Verified fixed on Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110713 Firefox/8.0a1 Fennec/8.0a1 

still reproducible on Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110713 Firefox/7.0a2 Fennec/7.0a2

Which Firefox is tracking?
Comment 17 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-14 21:44:14 PDT
(In reply to comment #16)
> Verified fixed on Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1)
> Gecko/20110713 Firefox/8.0a1 Fennec/8.0a1 
> 
> still reproducible on Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2)
> Gecko/20110713 Firefox/7.0a2 Fennec/7.0a2
> 
> Which Firefox is tracking?

The same fix is in Fx7, so I am worried that you can't verify there
Comment 18 Andreea Pod 2011-07-21 06:04:15 PDT
This is tracking Firefox 7, I verified again on today's build: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110720 Firefox/7.0a2 Fennec/7.0a2. Since I can still reproduce it I'm reopening it.
Comment 19 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-21 08:21:04 PDT
Fixed on Fx8. Set flags to track for fx7
Comment 20 Andreea Pod 2011-07-21 08:55:45 PDT
Verified fixed on Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110721 Firefox/8.0a1 Fennec/8.0a1 
Device: LG Optimus 2X
Comment 21 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-22 13:29:33 PDT
Since there is no real need to have this fixed on fx7 and it is fixed on fx8, I am changing the flags and we can move on.

Note You need to log in before you can comment on or make changes to this bug.