Binaries built for "i686 linux" not "i386 linux"

VERIFIED INVALID

Status

mozilla.org
Miscellaneous
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Moses Lei, Assigned: Dawn Endico)

Tracking

Details

(URL)

(Reporter)

Description

18 years ago
I'm almost sure this is in the wrong component, but I don't know where to put
it. In fact, maybe it should not be in Bugzilla at all. But a bugzilla
discussion is easier to keep track of.

The point is, the link on the mozilla.org home page has download links for "i386
linux" but this is misleading. The binaries are built for i686 (P-Pro and up)
and are optimized as such; they run extremely slowly or not at all on Pentium
(i586) or lower machines. In order to get mozilla running at a reasonable speed
on a Pentium machine, it was necessary for me to compile from source. I think
the links should be changed to read "i686 linux".

Please comment; sorry if this is out of place (if so mark INVALID and advise me
on who to contact about this).

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 45657 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
this is actually a mozilla.org web site bug that the web pages are referring to 
these as 386 binaries when they are 686 binaries.

reopening and changing product to mozilla.org.
Status: RESOLVED → UNCONFIRMED
Component: Build Config → Miscellaneous
Product: Browser → mozilla.org
Resolution: DUPLICATE → ---

Comment 3

18 years ago
reassigning to default component owner
Assignee: cls → mitchell

Comment 4

18 years ago
Reassigning to Dawn, who takes care of the websit.
Assignee: mitchell → endico
(Assignee)

Comment 5

18 years ago
The binaries we distribute are not optimized for 686. They'll run on 386
which is why the web site refers to them as 'i386'. The file names of the
binares are determined by what is reported by 'uname'. Since the binaries
were created on 686 machines that happens to get inserted into the file
name. My links on the home page really do link to builds that work on any
x86 processor. (of course, mozilla may be too bloated to run on other
processors, but that's another story =)

If you want to complain about the way the files are named, see bug
45657. This issue doesn't look very high on granrose's list but i'm sure
he would accept a patch. I think the code is in  mozilla/xpinstall/packager

Would it be better if the link said "x86" instead of i386?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

18 years ago
Yes, I think x86 would probably be more accurate than i386. I've had a lot of
trouble with running the builds on my pentium, which is why i filed the bug, but
I suppose there probably were other factors involved there.

Comment 7

18 years ago
why was this resolved invalid?  I can't verify it if I don't know the reason.
(Reporter)

Comment 8

18 years ago
I was under the impression that these were 686-optimized builds but Dawn says
that they are not, so this bug is invalid. Please verify that this is the case.

Comment 9

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.