Rename TryChooser's "macosx" and "linux" platform targets to "macos32" and "linux32"

RESOLVED DUPLICATE of bug 615705

Status

Release Engineering
General
P5
enhancement
RESOLVED DUPLICATE of bug 615705
8 years ago
5 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver])

(Reporter)

Description

8 years ago
TryChooser currently accepts the following platform targets:

  linux,linux64,macosx,macosx64,win32,maemo5-qt,android-r7,maemo5-gtk

It seems sensible to rename "linux" and "macosx" to "linux32" and "macosx32" for parallelism with "win32", "linux64", and "macosx64".  Right now, one might imagine that "linux" builds both linux32 and linux64.
I don't think we should do this. Within releng infrastructure, "linux" means linux 32-bit and "macosx" means either "ppc+i386 Universal build" or "i386 only build". We've already got other platform variations when interacting with other systems, and I don't want to introduce another one...
We already support variants/aliases in the try chooser syntax, so I think it's fine to add an alias for 'linux32' -> 'linux', etc.
there's also bug 615705 for adding 'desktop' and 'mobile' aliases, this bug can probably be handled at the same time.
Severity: normal → enhancement
Priority: -- → P5
Whiteboard: [tryserver]
Duping to the now all-encompassing 'user syntax improvements bug'
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615705
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.