TryChooser user choice syntax improvements

RESOLVED WONTFIX

Status

Release Engineering
General
P4
normal
RESOLVED WONTFIX
8 years ago
3 months ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

({trychooser})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver])

(Reporter)

Description

8 years ago
Now that bug 600296 landed, it's a bit tricky to say "build all desktop platforms but no mobile platforms".

TryChooser could improve this situation by adding two pseudo-platforms, "desktop" and "mobile", which correspond to all desktop and all mobile operating systems.
Priority: -- → P4
Whiteboard: [tryserver][simple]
Merging three bugs about new syntax options into one bug for better tracking and implementation.

From Bug 615709:

TryChooser currently accepts the following platform targets:

  linux,linux64,macosx,macosx64,win32,maemo5-qt,android-r7,maemo5-gtk

It seems sensible to rename "linux" and "macosx" to "linux32" and "macosx32"
for parallelism with "win32", "linux64", and "macosx64".  Right now, one might
imagine that "linux" builds both linux32 and linux64.

From bug 623953:

Support mix-n-match opt/debug in trychooser.
This shouldn't be too hard, if I add another option to the -b so that it's
opt/debug/both/mixnmatch then we can go through the user platforms for ones
with -dbg attached or something like that.
Summary: TryChooser should have --platform "desktop" and "mobile" aliases → TryChooser user choice syntax improvements
Whiteboard: [tryserver][simple] → [tryserver]
Duplicate of this bug: 615709
Duplicate of this bug: 623953

Updated

6 years ago
Whiteboard: [tryserver] → [tryserver][trychooser]

Updated

6 years ago
Keywords: trychooser
Whiteboard: [tryserver][trychooser] → [tryserver]
Found in triage.
Component: Release Engineering → Release Engineering: Developer Tools
QA Contact: hwine
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Assignee)

Updated

a year ago
Component: Tools → General
Product: Release Engineering → Release Engineering
I think try chooser is dead and/or dying since the advent of "./mach try fuzzy". I'm closing this.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.