Closed Bug 616130 Opened 10 years ago Closed 4 months ago

Need pref to disable tab tear off

Categories

(Firefox :: Tabbed Browser, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 74
Tracking Status
firefox74 --- fixed

People

(Reporter: admin, Assigned: jaso35)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

This problem occured for me many times specially in my netbook.
Some times I want to select an opened tab between my open tabs, ( with default touch mouse plane of netbook ) firefox move that tab to a new window !
Please add a feature to disable moving tabs to new window by drag / dropping them.

Reproducible: Always

Actual Results:  
The bug is clear


The bug is clear
Severity: normal → enhancement
Component: General → Preferences
OS: Windows 7 → All
QA Contact: general → preferences
Hardware: x86 → All
Summary: Block moving tabs to new window → Need pref to disable tab tear off
Component: Preferences → Tabbed Browser
QA Contact: preferences → tabbed.browser
Duplicate of this bug: 868800
In bug https://bugzilla.mozilla.org/show_bug.cgi?id=868800 I did not say it CAN be disabled, I said it MUST be disabled.

In other words: if there will be a user-defined option, its default should be "NO tab tear off".
I wander, why do Firefox developers insist to include features that nobody wants, nobody uses, and only interrupt the web surfing experience?
(In reply to t8av from comment #4)
> include features that nobody
> wants, nobody uses

How do you know (asking seriously)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Well, so far, I haven't met anyone who uses it.

I did meet many users who get annoyed by this feature.

The above add-on to disable tab tear off is very popular, and since I installed it, I am happy with it.

I am not a cynical person, but if I were cynical I would probably suggest to add many surprises to Firefox - clicking some areas of the browser will trigger interesting events such as tab tear offs, funny animations, etc'. Nobody will complain, but after a while everyone will move to Google Chrome.
I use tab tear off from time to time and it's more discoverable than a context menu this way. That being said, a built-in option to disable should be in there. Now that I think about it, it might even be helpful for disability access in the event that a user has trouble with fine pointer movements. (e.g. wants to reorder tabs but avoid tear off)

Note that the addon to disable this has only 8k users, which is virtually zero when it comes to addon user counts. A built-in option would certainly be more discoverable and get more use.
Keywords: uiwanted
Priority: -- → P5
See Also: → 727420

I would like to pick up this quite old request for an option to disable tab detachment.

I wrote a small patch to implement this behaviour but since i'm relatively new to firefox development, I have no idea who I can ask for review? A bit of help would be greatly appreciated!

Flags: needinfo?(dao+bmo)

(In reply to Jan Sonntag from comment #8)

I have no idea who I can ask for review?

Have a look at recently fixed bugs in this component and see who reviewed those patches. Also see the documentation:

  1. How to submit a patch
  2. Code review
  3. Modules/Firefox
Assignee: nobody → jaso35
Status: NEW → ASSIGNED
Attachment #9121383 - Attachment description: Bug 616130 - Add option to disable tab detaching r?gijs → Bug 616130 - Add option to disable tab detaching r=dao
Flags: needinfo?(dao+bmo)
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/951b824337c6
Add option to disable tab detaching r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

This will be resolved when the patch merges to mozilla-central.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Okay, thanks for letting me know :)

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
See Also: → 1439247
You need to log in before you can comment on or make changes to this bug.