Closed Bug 868800 Opened 6 years ago Closed 6 years ago

"Move to new window" when dragging the tab should be canceled because nobody uses it, and is often activated by mistake.

Categories

(Firefox :: Tabbed Browser, defect)

20 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 616130

People

(Reporter: t8av, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

I had few tabs opened, and accidentally dragged a tab to the main window.


Actual results:

The tab was detached and opened in a new window ("Move to new window" was activated by mistake).


Expected results:

Dragging a tab should never cause it to be opened in a new window.

This feature of auto-detachment is helpful for 0.0001% of the users and causes problems to the rest who often open tabs in new windows unintentionally.

It also happens at times of browser slowness even if the user does not really drag the tab (see some other bugs about this issue).
It's called tab tearing.
(In reply to Loic from comment #1)
> It's called tab tearing.

Nice term. It is also tearing my heart whenever more windows are unintentionally added to my many already opened windows.
Thanks, I will probably use it.

However, I must say it is ridiculous that an ADD-ON is needed to fix Firefox bugs.

(Many occurrences of unintentional actions is definitely a bug).
bug 616130, bug 727420
Component: Untriaged → Tabbed Browser
OS: Windows 7 → All
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616130
You need to log in before you can comment on or make changes to this bug.