Possible memory leak when deleting IMAP e-mails.

RESOLVED DUPLICATE of bug 538378

Status

RESOLVED DUPLICATE of bug 538378
8 years ago
8 years ago

People

(Reporter: vik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101129 Thunderbird/3.1.7

I have multiple IMAP accounts set up on my Thunderbird. One of those accounts has over 200,000 e-mails in it. When I tried to delete a large amount of e-mails (10,000 or so), Thunderbird experienced a massive slow down and froze up until it finished deleting the e-mails. When I tried to delete even more e-mails (100,000+), it simply crashed after being frozen for a long time. While investigating, I noticed that when I deleted e-mails from Thunderbird the memory footprint, Working Set (Memory) in Task Manager, rose to over 1GB. The more e-mails I deleted, the higher it went. Thunderbird retained a 1GB+ memory footprint throughout and after the delete operation. Neither letting it sit for a while nor emptying my trash folder helped. The only way I could get this to return to normal is by restarting Thunderbird. I suspect a memory leak.

On a side note, just viewing the inbox with over 200,000 e-mails resulted in a memory footprint of over 400MB.

Reproducible: Always

Steps to Reproduce:
1. Select a bunch of IMAP messages.
2. Press delete.
3. Monitor task manager's "Working Set (Memory)" column.
Actual Results:  
Thunderbird had a memory footprint of over 1GB.

Expected Results:  
Either retained a normal memory footprint or experienced an increase in memory usage during deletion but freed it up afterwards.

Addon list:
Contacts Sidebar 0.8pre2
Extra Folder Columns 1.1
Quicktext 0.9.10.1

Updated

8 years ago
Whiteboard: dupme
I believe it's re-discovery of bugs listed in bug 506509 comment #14. Even when local mail folder and Shift+Delete, phenomenon of bug 583365 comment #1 can be observed, unless swap file size is limited by OS setting(expansion of swap is pohibited by user). IMAP case is worse than local mail folder case, because not local file access only.
As IMAP case, duping to bug 538378 is appropriate?
(Reporter)

Comment 2

8 years ago
I would say this is essentially the same as bug 538378. Going to go ahead and mark it as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538378
You need to log in before you can comment on or make changes to this bug.