After close Add-ons Manager, tab should go back to recent use tab.( recent use tab should be selected)

RESOLVED FIXED in Firefox 4.0b10

Status

()

Firefox
General
--
major
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
Firefox 4.0b10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Whiteboard: fixed by bug 593687 [AOMTestday][AddonsRewrite])

(Reporter)

Description

7 years ago
After landing New Add-ons Manager Bug 550048,
Open Add-ons Manager, and close it, Minefield forget recently selected tab.
This is annoying. and regression of Bug 550048.

Prior to landing New Add-ons Manager, 
After Close Add-ons Manager Dialog, selected tab in browser window is preserved, 

Reproducible: Always

Steps to Reproduce:
1. Start Minefield
2. Open several tabs
3. Select any tab (not a last tab) 
4. Open Add-ons Manager (Ctrl+Shift+A)
5. Close Add-ons Manager Tab

Actual Results:
 A tab of the left or right of Add-ons Manager is selected.

Expected Results:
 Recently selected tab should be selected.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: regression
Target Milestone: --- → Firefox 4.0

Comment 1

7 years ago
confirmed in:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre ID:20101202044839
Hardware: x86 → All
Target Milestone: Firefox 4.0 → ---
Whiteboard: [AOMTestday]
blocking2.0: ? → .x
Duplicate of this bug: 633915
Whiteboard: [AOMTestday] → [AOMTestday][AddonsRewrite]

Comment 3

6 years ago
Has this been fixed? I don't see this bug in Firefox 5 or Firefox 8 on Windows XP.

Comment 4

6 years ago
Seems fixed by Bug 593687.

Comment 5

6 years ago
Last good nightly: 2011-02-11
First bad nightly: 2011-02-12

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ed3464aaa92&tochange=9698ac3f1c61

Updated

6 years ago
Component: Tabbed Browser → General
Depends on: 593687
QA Contact: tabbed.browser → general
Whiteboard: [AOMTestday][AddonsRewrite] → fixed by bug 593687 [AOMTestday][AddonsRewrite]
Target Milestone: --- → Firefox 4.0b10

Updated

6 years ago
Blocks: 576669

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.