Last Comment Bug 616699 - Address Book Output Panel does not read (or overrides) GTK theme settings for background, text color.
: Address Book Output Panel does not read (or overrides) GTK theme settings for...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
-- minor (vote)
: seamonkey2.1b2
Assigned To: skyalmian
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-04 08:06 PST by skyalmian
Modified: 2011-01-03 07:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.29 KB, patch)
2010-12-04 19:07 PST, skyalmian
neil: review+
Details | Diff | Splinter Review
"hg diff -p -U 8 addressbook.css > addressbook2.txt" output. r=Neil [Checkin: comment 14] (1.29 KB, patch)
2010-12-05 15:26 PST, skyalmian
philip.chee: review+
Details | Diff | Splinter Review

Description User image skyalmian 2010-12-04 08:06:44 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.17pre) Gecko/20101201 SeaMonkey/2.0.12pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.17pre) Gecko/20101201 SeaMonkey/2.0.12pre

While the Address Book's list of contacts and address book panels (top row and left column) adhere to whatever setting the GTK theme is set to, namely text and background color, the output panel below overrides with white background and white text. This is only noticeable on dark GTK themes with black backgrounds and white or gray text.

Reproducible: Always

Steps to Reproduce:
1. Switch to a dark-themed GTK theme where black backgrounds are the norm.



A screenshot for visual example:
http://sky.sploitz.com/bugzilla/seamonkey-address-book.png
Comment 1 User image rsx11m 2010-12-04 15:06:27 PST
This looks like the SeaMonkey equivalent of Thunderbird bug 351736?
Address book backend is shared code, but the themes aren't...
Comment 2 User image skyalmian 2010-12-04 16:02:40 PST
Yep... I incorporated the changes into addressbook.css from "Comment on attachment 375176 [details] [diff] [review]" and tested... Like Brian said: "looks good", with and without dark GTK theme. "The fix v2" needs to be incorporated into addressbook.css.
Comment 3 User image rsx11m 2010-12-04 17:18:50 PST
Since you've worked it out already, do you like to post a patch for review? :-D
Comment 4 User image skyalmian 2010-12-04 19:07:30 PST
Created attachment 495309 [details] [diff] [review]
Patch

I've never done any actual coding before and this is first time doing anything... Does this count?
Comment 5 User image rsx11m 2010-12-04 21:13:24 PST
Comment on attachment 495309 [details] [diff] [review]
Patch

Looks good to me, I'm asking Neil for review on your behalf.
Comment 6 User image neil@parkwaycc.co.uk 2010-12-05 02:51:09 PST
Comment on attachment 495309 [details] [diff] [review]
Patch

> .CardViewLink {
>-  color: blue;
>-  text-decoration: underline;
>+  color: -moz-nativehyperlinktext;
Why are you removing the underlining?
Comment 7 User image rsx11m 2010-12-05 09:27:04 PST
The Thunderbird themes have "text-decoration: underline;" defined later as part of the "html|a" rules, SeaMonkey's classic theme doesn't have that.
Comment 8 User image neil@parkwaycc.co.uk 2010-12-05 13:50:39 PST
Comment on attachment 495309 [details] [diff] [review]
Patch

> .CardViewLink {
>-  color: blue;
>-  text-decoration: underline;
>+  color: -moz-nativehyperlinktext;
r=me if you restore the underlining.
Comment 9 User image skyalmian 2010-12-05 15:26:46 PST
Created attachment 495413 [details] [diff] [review]
"hg diff -p -U 8 addressbook.css > addressbook2.txt" output. r=Neil [Checkin: comment 14]

Re-added the line...
Comment 10 User image rsx11m 2010-12-05 17:22:00 PST
This should be approved after Neil's r+, unless I'm reading anything wrong.
Thus, I'm setting the "checkin-needed" keyword for someone to push on trunk.
Comment 11 User image skyalmian 2010-12-06 17:10:06 PST
Thank you for everything you've done... This wouldn't have been solved had you not found the similar Thunderbird bug. :} I did look before posting this, but I had limited my searches to SeaMonkey...
Comment 12 User image rsx11m 2010-12-06 17:47:01 PST
You are welcome, and congratulations for your first SeaMonkey patch!
Comment 13 User image rsx11m 2010-12-18 09:20:01 PST
I'm not aware of any tree closures on trunk, thus a friendly ping for a push?
Comment 14 User image Jens Hatlak (:InvisibleSmiley) 2010-12-18 09:56:29 PST
Comment on attachment 495413 [details] [diff] [review]
"hg diff -p -U 8 addressbook.css > addressbook2.txt" output. r=Neil [Checkin: comment 14]

http://hg.mozilla.org/comm-central/rev/1e36326c45e3
Comment 15 User image Jens Hatlak (:InvisibleSmiley) 2010-12-18 09:57:17 PST
Thanks!
Comment 16 User image neil@parkwaycc.co.uk 2010-12-19 08:18:12 PST
Comment on attachment 495413 [details] [diff] [review]
"hg diff -p -U 8 addressbook.css > addressbook2.txt" output. r=Neil [Checkin: comment 14]

> .CardViewLink {
>-  color: blue;
>   text-decoration: underline;
>+  color: -moz-nativehyperlinktext;
[The slip over the underline has caused the change in colour to migrate!]

Note You need to log in before you can comment on or make changes to this bug.