Closed Bug 616838 Opened 11 years ago Closed 3 years ago

Firefox can hang due to alert box in embed, object, applet src

Categories

(Toolkit :: Notifications and Alerts, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
blocking2.0 --- -

People

(Reporter: BijuMailList, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is similar to Bug 613800 but not a regression it also happens in Fx3.6, also more easily reproduced in Fx3.6 


STR for Fx3.6 
1. Go to attachment alert_stuck.html
2. Wait 5 sec for alert box to appear
3. Note down the message on the alert box
4. Drag the alert box, you will see another alert below it.
5. Drag the second alert box (in step 4), you will third alert box, 
6. Select third alert box
7. Close second or third alert box
8. Drag around other alert boxes, as well as Firefox window
9. At some point Firefox HANGS for a while
10. if Firefox is not hanging close all alert and retest.


STR for Fx4
1. Go to attachment alert_stuck.html
2. Wait 5 sec for alert box to appear
3. Create few new tabs
4. Keep switching tabs
5. Move Firefox main window around
6. repeat step 4 and 5 few times
7. At some point Firefox HANGS for a while 
8. if Firefox is not hanging close all alert and retest.

Why do we want to allow alert/confirm/prompt in URLs for embed, object, applet?
Blocks: eviltraps
Attached file alert_stuck.html
blocking2.0: --- → ?
Not a regression, hang isn't permanent, narrow case -> blocking-.
blocking2.0: ? → -
The STR for Fx4 is rather vague, and I cannot reproduce this.
Try doing it in  Fx3.6 using STR for that.
It is more easily reproduced there, even though I first found this in Fx4, it is not that easy to reproduce in Fx4. BTW the result is same in Fx4, and Fx3.6.
Bulk move to Toolkit::Notifications and Alerts

Filter on notifications-and-alerts-component.
Component: General → Notifications and Alerts
Triaging Evil Trap Bugs at the moment and it seems this one is not reproduceable anymore. I can move the browser around and nothing hangs. After 7 years I am going to close this one as INVALID.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.