[Quick Filter bar] Missing tag icon

RESOLVED FIXED in Thunderbird 3.3a2

Status

Thunderbird
Theme
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Aureliano, Assigned: Paenglab)

Tracking

({icon, polish, regression})

Trunk
Thunderbird 3.3a2
x86
Windows 7
icon, polish, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 495464 [details]
screenshot

It seems that the bar has a place for tag icon but the icon isn't there.
(Assignee)

Comment 1

7 years ago
Created attachment 495548 [details] [diff] [review]
Patch

I overseen this reference to a deleted file in Bug 545557. This patch uses the new icon. Instead of an other -moz-image-region, new icon set has only one state, I'm using opacity for disabled state.

I set the same people for review, because they know the previous patches.
Attachment #495548 - Flags: ui-review?(nisses.mail)
Attachment #495548 - Flags: review?(bwinton)
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 2

7 years ago
Created attachment 495550 [details]
screenshot showing tag icon in enabled and disabled state

Screenshot to show how the tag icon looks with the other icons. Also showing tag icon in disabled state.
(Assignee)

Updated

7 years ago
Blocks: 545557
This looks good. We should probably make the other icons monochrome as well, but I'll spin that off as a separate patch.
Before I give a ui-r+, how do I trigger the disabled state?
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
> Before I give a ui-r+, how do I trigger the disabled state?

I don't know how to trigger the disabled state in normal work. I have never seen it disabled.

I forced it with DOMi by setting the DOM Node to disabled=true.
Comment on attachment 495548 [details] [diff] [review]
Patch

It don't seem like the other icons use a disabled state in the css, but this is not a code review, so ui-r+ :)
Attachment #495548 - Flags: ui-review?(nisses.mail) → ui-review+
(In reply to comment #6)
> Comment on attachment 495548 [details] [diff] [review]
> Patch
> 
> It don't seem like the other icons use a disabled state in the css, but this is
> not a code review, so ui-r+ :)

Err...sorry, it seems like it did before too. Forget what I said. :)
Comment on attachment 495548 [details] [diff] [review]
Patch

Well, I've looked and I've looked and I've looked for something to complain about on this bug, but I just can't find anything.  ;)

r=me.
Attachment #495548 - Flags: review?(bwinton) → review+
(Assignee)

Updated

7 years ago
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/870564ed3d78
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a2

Comment 10

7 years ago
Comment on attachment 495548 [details] [diff] [review]
Patch

> #qfb-tags[disabled] {
>-  -moz-image-region: rect(48px, 384px, 72px, 360px) !important;
>+  opacity: .4;
> }

Looks like you want to set opacity for .toolbarbutton-icon only instead of whole button...
Azat: can you file that as a new bug and attach a patch to fix that?
(Assignee)

Comment 12

7 years ago
I overseen Azats comment. Filed Bug 626735.
You need to log in before you can comment on or make changes to this bug.