Themes show the Buttons at the wrong side

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: loxnews, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by backout])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.9.2.13) Gecko/20101206 Lightning/1.0b2 Mnenhy/0.8.3 Thunderbird/3.1.7

When I select a mail the buttons "Reply, Forward, Archive, ..." are not shown on the right side like they should but on the left. I tried this with the styles Silvermail, Tangobird and Gnome. Only when I use the sdandard theme the buttons are shown at the right side.

Reproducible: Always

Steps to Reproduce:
1. Use a theme that is not the standard one
2. Select a mail

Comment 1

8 years ago
There has been a change for right-to-left languages, made by bug 594369, allowing those to place the buttons to the left as preferred by such locales. This required a change in the CSS code of the themes. Thus, it's fixed in the default themes for all platforms, but 3rd-party themes need to catch up with that modification. You may want to notify the authors of the affected themes.

I'm closing this bug as INVALID as it's not a Thunderbird but 3rd-party issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Depends on: 594369
Resolution: --- → INVALID
Actually, we possibly shouldn't have taken bug 594369 on the branch. I'll be considering this with drivers later.
Status: RESOLVED → REOPENED
blocking-thunderbird3.1: --- → ?
Ever confirmed: true
Resolution: INVALID → ---
I've tried this out with silvermel and it does indeed show the problem.
Status: REOPENED → NEW

Comment 4

8 years ago
Ok, your call. I was about to post a heads-up in the MozillaZine Themes forum but will hold back on that one until you've decided whether or not to back out that patch. It likely would be too late for many theme developers to make those changes by the intended release on Thursday...
Fixed by backout of bug 594369, we will be rebuilding 3.1.7 to incorporate this change.

Tekin: thanks for reporting this, nice catch.
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Keywords: regression
Whiteboard: [fixed by backout]
blocking-thunderbird3.1: ? → ---
You need to log in before you can comment on or make changes to this bug.