Last Comment Bug 617333 - Port |Bug 594586 - Screen reader accessibility for doorhanger notifications| to SeaMonkey
: Port |Bug 594586 - Screen reader accessibility for doorhanger notifications| ...
Status: RESOLVED FIXED
[doorhanger]
:
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1b2
Assigned To: Serge Gautherie (:sgautherie)
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 594586 619309
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 08:28 PST by Serge Gautherie (:sgautherie)
Modified: 2011-02-07 20:34 PST (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
(Av1) Just copy it [Checked in: Comment 4] (1005 bytes, patch)
2010-12-07 08:32 PST, Serge Gautherie (:sgautherie)
neil: review+
Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2010-12-07 08:28:27 PST

    
Comment 1 Serge Gautherie (:sgautherie) 2010-12-07 08:32:59 PST
Created attachment 495841 [details] [diff] [review]
(Av1) Just copy it
[Checked in: Comment 4]

Please double-check, as I'm not sure how to "test" this.
Comment 2 neil@parkwaycc.co.uk 2010-12-07 16:33:39 PST
(In reply to comment #1)
> Please double-check, as I'm not sure how to "test" this.
The problem is that our URLBarMouseDown/ClickHandler functions focus the URL bar when we don't want them to. (This also affects the EV icon. I didn't try the feed or bookmark icons.) With that fixed, you should find that clicking the doorhanger anchor icon focuses the icon. This patch then changes it so that clicking the doorhanger anchor icon focuses the button in the doorhanger. But I can't give it review until our URL bar is fixed.
Comment 3 neil@parkwaycc.co.uk 2011-01-05 15:33:31 PST
Comment on attachment 495841 [details] [diff] [review]
(Av1) Just copy it
[Checked in: Comment 4]

Note: patch was bitrotted by bug 617661 so I had to apply it manually.
Comment 4 Serge Gautherie (:sgautherie) 2011-01-05 16:48:44 PST
Comment on attachment 495841 [details] [diff] [review]
(Av1) Just copy it
[Checked in: Comment 4]

http://hg.mozilla.org/comm-central/rev/cba30b4e8793

Note You need to log in before you can comment on or make changes to this bug.