Restrict the OpenSearch function to the search box.

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: Yhn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; zh-CN; rv:1.9.1.15) Gecko/20101027 SeaMonkey/2.0.10
Build Identifier: SeaMonkey/2.1 Beta

In order not to lose those users who are fund to use the display-search-result-in-searchbar and integrating-results-from-2-or-more-engines functions, it's suggested that we should restrict the OpenSearch function to the 401417-search-box. And since the MycroftSearch does not supply enough information to implement all functions in the traditional searchbar, it's also suggested to restrict MycroftSearch to the new search-box.

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
N/A

N/A
(Reporter)

Updated

8 years ago
Depends on: 401417

Comment 1

8 years ago
This sounds rather confusing to me...

Comment 2

8 years ago
We will not restrict functionality to a certain interface, but always support adding others if wanted. And there has never been a "searchbar" in SeaMonkey. You might mean the search sidebar, but I have no clue what this bug is about, so it's INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
No longer depends on: 401417
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> We will not restrict functionality to a certain interface, but always support
> adding others if wanted. And there has never been a "searchbar" in SeaMonkey.
> You might mean the search sidebar, but I have no clue what this bug is about,
> so it's INCOMPLETE.

I meant the search sidebar, and will repost a new bug to correct this spelling.
(Reporter)

Comment 4

8 years ago
Seemingly I can complete this bug without repost it. Here's the completion: 

Change all "searchbar" to "search sidebar"
All "searchbox" mean that in bug 401417
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Updated

8 years ago
Depends on: 401417

Comment 5

8 years ago
OK, so we will just not work on this, then. And it's still confusing what you really want.
Also, I'll repeat: We will not restrict functionality to a certain interface but always support adding others if wanted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> OK, so we will just not work on this, then. And it's still confusing what you
> really want.
> Also, I'll repeat: We will not restrict functionality to a certain interface
> but always support adding others if wanted.

I mean, to make the OpenSearch optional, that is, allow the end-user to disbble OpenSearch in order to keep the sidebar displaying scraped search results.

The easiest way to perform that is to simply restrict the OpenSearch function to the Firefox-like searchbar. 

You told me that you will never restrict functionality but you've already restricted the sidebar displaying scraped search results function to versions up to 2.0.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)

Nobody will hope to use OpenSearch in search sidebar unless Firefox-like searchbar not performed, because the advantages of search sidebar completely don't work on OpenSearch. OpenSearch doesn't support sidebar displaying scraped search results, and OpenSearch doesn't support search results integration. OpenSearch doesn't support any features of search sidebar so it's not a bad idea to restrict the OpenSearch function to the Firefox-like searchbar.

Comment 8

7 years ago
We won't restrict the OpenSearch functionality to a certain piece of UI.

It's a sad fact that OpenSearch as such doesn't support parsable search results.
While some of us investigate the possibility to teach OpenSearch such a capability, this may not successful at all and for sure is beyond this bug.

The restriction requested here will never happen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> We won't restrict the OpenSearch functionality to a certain piece of UI.
> 
> It's a sad fact that OpenSearch as such doesn't support parsable search
> results.
> While some of us investigate the possibility to teach OpenSearch such a
> capability, this may not successful at all and for sure is beyond this bug.
> 
> The restriction requested here will never happen.

This is irresponsible: you did not notice that (see comment 4 of bug 599297) not only doesn't OpenSearch support parsable search, but OpenSearch blocks the entire “sidebar displaying scraped
search results” function (incl.  for non-OpenSearch search) as well. 

So if you don't restrict the OpenSearch functionality to a certain piece of UI, the “scraped search results” function will be REMOVED (for its incompatibility with OpenSearch). To remove or to restrict, you must make a choice.

“To teach OpenSearch such a capability” is a good idea, but will never performed.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 10

7 years ago
We have removed the old search scraping functionality and we will not add it back. Feel free to write an add-on that does it, but this bug is WONTFIX, and if you open it again, I will ask Bugzilla administrators to disable your account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.