No action if there is a non-alphabetical character in the sync key

VERIFIED FIXED

Status

Cloud Services
Firefox Sync: Backend
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: ashah, Assigned: philikon)

Tracking

unspecified
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Sync on Minefield (20101210)

Open Sync. Click Setup sync and then click "I dont have the device with me".
This will take you to the login screen. There, type in your correct account name and password. Then in the sync key, type in a wrong key, BUT, put a non alphabetical character in the sync key, like a space, or a $, or a # etc. 
For eg. "ssdf sdfds" or "ewr#sdfwe$"

Expected result:
It should give an error for wrong sync key

Actual result:
Nothing happens. I can click on the continue button but nothing happens on the screen.

Note: If you remove non-alphabetical characters from the sync key(for eg: type "sdfsdf"), it will check and give you the error for wrong sync key. But this does not happen if non-alphabetical characters are present
I can confirm this. Working on a fix.
Assignee: nobody → philipp
blocking2.0: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Updated

7 years ago
Duplicate of this bug: 618956

Updated

7 years ago
blocking2.0: ? → beta8+
(Assignee)

Updated

7 years ago
Component: Firefox Sync: UI → Firefox Sync: Backend
QA Contact: sync-ui → sync-backend
Created attachment 497398 [details] [diff] [review]
v1

Do not hit generateEntry when we have an old style Sync Key.
Attachment #497398 - Flags: review?(mconnor)
(Assignee)

Updated

7 years ago
Whiteboard: [has patch][needs review mconnor]
Attachment #497398 - Flags: review+

Updated

7 years ago
Attachment #497398 - Flags: review?(mconnor) → review+
Landed on fx-sync:
https://hg.mozilla.org/services/fx-sync/rev/1418982c9333

Merged to mozilla-central:
https://hg.mozilla.org/mozilla-central/rev/43a54dd56ccd
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Whiteboard: [has patch][needs review mconnor]
still seeing this on nightly trunk builds from 20101214
using a hyphenated key.

fixing this would make bug 618336 tolerable.
Blocks: 618336
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: in-testsuite?

Updated

7 years ago
Duplicate of this bug: 618336

Comment 7

7 years ago
Using Portable FF 3.6 on Windows, I have gotten errors with the latest version of Sync when mis-spelling my Sync key (a phrase with many spaces and periods).
Please file a separate bug, this is on the Fx4 in-product UI.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
No longer blocks: 618336
Verified fixed with the first build of Beta8.  CnP of a hyphenated key from 1.5.1 was accepted when adding beta8 to the existing account.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.