Closing last non-pinned tab causes tab bar to collapse

RESOLVED DUPLICATE of bug 612477

Status

()

RESOLVED DUPLICATE of bug 612477
8 years ago
8 years ago

People

(Reporter: sparky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre

If you've removed all of the toolbar buttons from the tab bar, and close all of the non-pinned tabs, the tab bar collapses and the pinned tabs overlap the nav bar.

My guess is that this happens because the pinned tabs are absolutely positioned, so the tab bar is effectively empty.

Reproducible: Always

Steps to Reproduce:
1. Run Firefox with a new profile
2. Remove the "New Tab", "List all tabs", and "Tab Grouops" toolbar items.
3. There should be 2 'first start' tabs open. Pin one and close the other.
Actual Results:  
The tab bar is collapsed and the pinned tabs overlap the nav bar.

Expected Results:  
The tab bar does not collapse.
(Reporter)

Comment 1

8 years ago
Created attachment 497004 [details]
Screenshot of the problem

Comment 2

8 years ago
(In reply to comment #1)
> Created attachment 497004 [details]
> Screenshot of the problem

Duplicate of bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=612477
AppTabs(pinned tabs) drops down into the Navigation Bar when only AppTabs(pinned tabs) are present on Tabbar after restarting and closing the newly generated Tab next to them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Linux → All
Resolution: --- → DUPLICATE
Duplicate of bug: 612477
You need to log in before you can comment on or make changes to this bug.