SeaMonkey disables filters after running them automatically--but not every time.

RESOLVED DUPLICATE of bug 594746

Status

defect
RESOLVED DUPLICATE of bug 594746
9 years ago
9 months ago

People

(Reporter: haleybux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11

SeaMonkey, Mail & Newsgroups, Tools, Message Filters..., Message Filters dialog box, Enabled column: After running filters automatically, SeaMonkey diables the filters it has run--that is, it changes the check mark in the Enabled column to a dot.  This does not happen every time SeaMonkey applies the filters, but it happens with regularity--perhaps every other time.  It is highly irritating.

Reproducible: Always

Steps to Reproduce:
1.  Receive new email to which SeaMonkey will apply a filter--say to move the email to a different folder.
2.  Try this several times with new email that will be processed by the same filter
3.  Check the setting in the Enabled column in the Message Filters dialog box.
Actual Results:  
Check mark will by changed to dot--that is, SeaMonkey will disable the filter.

Expected Results:  
Existing check marks should not be changed.

May not occur every time but does happen with regularity.

Comment 1

9 years ago
At least two other people are experiencing this bug so Confirming.

More details over in the Mozillazine thread:
<http://forums.mozillazine.org/viewtopic.php?f=5&t=1664545>
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
You can read my litterature for this problem in the bug #594746
I am seeing this issue after exiting and restarting Seamonkey. Some of the filters get deactivated and the mails are kept in the inbox. I have more than 50 filters and it is annoying to activate the filters again. Normally between 3 to 10 filters get deactivated.

Comment 4

7 years ago
With the 2.8 that was correct, With the 2.9.1 versions that  began again !

Comment 5

7 years ago
I've been seeing what appears to be the same bug since SeaMonkey 2.8 on Linux.  I'm now running 2.9.1.  Is this possibly the same as Bug #594746, as indicated by bertranddepommery in Comment #2?
Yes, both tickets describe the same bug. I have this issue for a very long time not just since the last updates.

Comment 7

7 years ago
Hello
With 2.9.1 that is as if one filter actved, when it is utilised, is desactived instead of get his job...
sincerly
Bertrand

Comment 8

7 years ago
I think this is a major issue. I don't want lots of unimportant email cluttering my inbox every day.

Here's what I posted on https://bugzilla.mozilla.org/show_bug.cgi?id=594746:

Happens to me as well. I've only noticed it since I upgraded from 2.7 to 2.8, Windows 7 x64.
In my case it's always the same filter that gets disabled:

1. It's an 'any' filter, with a lot of 'from contains' alternatives, move to a given folder. Most of the hits are on 'from contains @facebook'.
2. I moved 'from contains @facebook' to a NEW filter, move to the same folder.
3. Now the old filter doesn't get disabled anymore, but the NEW one does.

I even have the check on startup and check periodically disabled. It makes no difference.

Comment 9

7 years ago
Is this still happening? There was a similar problem in Thunderbird recently (and is fixed).
Are all your folders in the left folder pane expanded when you start Seamonkey (or receive new messages)?
This issue still exists. Just had it yesterday.

The folders are sometimes expanded like in the previous sessions, sometimes the newsgroups are opened which were closed in the last sessions (would be another bug report).
hello
don't foget this bug ! it isn't resoved in 2.13.1 !

Updated

9 months ago
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594746

Updated

9 months ago
Summary: SeaMonkey diables filters after running them automatically--but not every time. → SeaMonkey disables filters after running them automatically--but not every time.
You need to log in before you can comment on or make changes to this bug.