[D3D] Flash plugin or WebM video paints over horizontal scrollbar

VERIFIED DUPLICATE of bug 614651

Status

()

defect
VERIFIED DUPLICATE of bug 614651
9 years ago
9 years ago

People

(Reporter: mozbugz, Assigned: bas.schouten)

Tracking

({regression})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

Posted image Youtube WebM video
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre

I been noticing this with D3D9 using this URL - (http://thebubble.msn.com) on a 1024x768 screen in maximized mode while testing bug 579597 (large enough the plugin overlaps the scrollbar, scrolling up and down I can trigger it)

Horizontal scrollbar almost appears to be transparent when it first loads the plugin.

But then I noticed it will occur with Youtube WebM video as well if the window is sized correctly. 

Basically the horizontal scrollbar is covered up by the flash plugin or WebM video on Youtube if it bisects the plugin area - basically I make the window small enough so that the horizontal scrollbar overlaps.  You'll see by the attached screenshot, it doesn't even have to be playing for this to happen. Since it will be that way once the video stops. 


Not a problem:
Its not a problem if I disable D3D9.
Though Youtube Flash doesn't look like it is affected.

Adapter Description NVIDIA GeForce 7050 / NVIDIA nForce 610i
Vendor ID10de
Device ID07e3
Adapter RAM 256
Adapter Drivers nvd3dum
Driver Version 8.17.12.6099
Driver Date 10-16-2010
Direct2D Enabled true 
DirectWrite Enabled true
GPU Accelerated Windows 1/1 Direct3D 9
WebM video link I been testing with:
http://www.youtube.com/watch?v=BH0BNbwqNK8&webm=1&html5=1
Blocks: d3d9-layers
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/29d2042e54aa
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre ID:20101021134825
Fails:
http://hg.mozilla.org/mozilla-central/rev/f4a06cca9fb9
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre ID:20101021143501
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=29d2042e54aa&tochange=f4a06cca9fb9
Regressed by:73f8c0079bc1	Bas Schouten — Bug 584494: Avoid creating intermediate surfaces in D3D9 layers. r=roc a=blocking-betaN

And maybe related to Bug 614651 - Canvas element(Google images) show through the add-on bar and horizontal scrollbar with D3D9:on
Blocks: 584494
Whats interesting is that vertical scrollbar doesn't have this problem.
It makes me sad, but it's only the horizontal scrollbar. I want this fixed, but I think we can release without this fix.
Assignee: nobody → bas.schouten
blocking2.0: ? → -
Keywords: regression
I think we should try to fix this. It's unlikely to be just the horizontal scrollbar, it's likely to be a fundamental layer rendering bug.
blocking2.0: - → ?
I can reproduce this. The regression window is certainly interesting. I agree with roc that this is indicative of a more fundamental rendering issue.
blocking2.0: ? → final+
This will be fixed by bug 614651.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614651
Verified this is fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.